Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2219

upgrade from 1.4 to 1.8 causes a problem

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: svn-tag-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Linux
    • Similar Issues:

      Description

      I upgraded my successfully running Hudson from svn_tag version 1.4 to svn_tag
      1.8, and then ran my simplest job (single repository, existing tree in
      "last_successful" tag directory). It ran, but when it went to create the new
      tag, it had this error:

      moduleLocation: Remote ->http://svn/svn/trunk/apollo12/res
      Failed to parse tag base URL 'http://svn/svn/tags/last-successful/res'. svn: URL
      'http://svn/svn/tags/last-successful/res/..' contains .. element
      Delete old tag http://svn/svn/tags/last-successful/res.
      FATAL: null
      java.lang.NullPointerException
      at
      org.tmatesoft.svn.core.wc.DefaultSVNRepositoryPool.createRepository(DefaultSVNRepositoryPool.java:210)
      at
      org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:297)
      at
      org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:289)
      at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:479)
      at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:464)
      at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:430)
      at hudson.plugins.svn_tag.SvnTagPlugin.perform(SvnTagPlugin.java:209)
      at hudson.plugins.svn_tag.SvnTagPublisher.perform(SvnTagPublisher.java:79)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:309)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:297)
      at hudson.model.Build$RunnerImpl.cleanUp(Build.java:127)
      at hudson.model.Run.run(Run.java:823)
      at hudson.model.Build.run(Build.java:84)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)

      It did delete the existing directory under tags, but failed to create a new one.
      I didn't do any reconfiguring of the job - I only updated the svn_tag plugin
      version (so the "Tag Base URL" is unchanged at
      "http://svn/svn/tags/last-successful/res")

      Thanks for your efforts!

        Attachments

          Activity

          k2nakamura k2nakamura added a comment -

          I could reproduce the problem and started to look into this.

          k2nakamura k2nakamura added a comment -

          Added the test case to reproduce the problem and fixed the issue. Please verify
          with version 1.9.

          mikenereson mikenereson added a comment -

          I am seeing the same errors in 1.9

          Hudson 1.225 and 1.258 (just upgraded today to try to curb this issue)
          svn-tag 1.9

          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESSFUL
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 12 seconds
          [INFO] Finished at: Mon Nov 03 14:07:04 EST 2008
          [INFO] Final Memory: 16M/150M
          [INFO] ------------------------------------------------------------------------
          moduleLocation: Remote ->file:///usr/local/kmapp/svnrepos/project1
          Failed to parse tag base URL 'project1/tags'. svn: Malformed URL
          'file:/usr/local/kmapp/svnrepos/project1/tags'
          There was no old tag at project1/tags.

          FATAL: null
          java.lang.NullPointerException
          at
          org.tmatesoft.svn.core.wc.DefaultSVNRepositoryPool.createRepository(DefaultSVNRepositoryPool.java:210)
          at
          org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:297)
          at
          org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:289)
          at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:479)
          at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:464)
          at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:430)
          at hudson.plugins.svn_tag.SvnTagPlugin.perform(SvnTagPlugin.java:205)
          at hudson.plugins.svn_tag.SvnTagPublisher.perform(SvnTagPublisher.java:79)
          at
          hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:319)
          at
          hudson.maven.MavenModuleSetBuild$RunnerImpl.cleanUp(MavenModuleSetBuild.java:478)
          at hudson.model.Run.run(Run.java:856)
          at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:205)
          at hudson.model.ResourceController.execute(ResourceController.java:70)
          at hudson.model.Executor.run(Executor.java:88)

          k2nakamura k2nakamura added a comment -

          I haven't tested with "file" svn protocol. Can you try with "http" protocol? If you have the reason to stick
          with file protocol, please create another enhancement issue, but I'm afraid the priority is quite low because
          http protocol should cover more uses cases.
          If it works with http protocol, please close this case.

          mikenereson mikenereson added a comment -

          I have to use file for permissions reasons. Thanks for at least confirming that
          file does not work.


            People

            • Assignee:
              k2nakamura k2nakamura
              Reporter:
              dani_ dani_
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: