Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22193

Add an option to disable the Jar caching

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Sometimes the JAR caching causes significant issues (e.g. JENKINS-20913). It would be great to have a CLI option, which completely disables the caching on the node.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev created issue -
            oleg_nenashev Oleg Nenashev made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-20913 [ JENKINS-20913 ]
            jglick Jesse Glick added a comment -

            Seems like a fix of JENKINS-18578 would solve that kind of issue in a better way. Why not work on that instead of disabling JAR caching altogether?

            jglick Jesse Glick made changes -
            Link This issue is related to JENKINS-18578 [ JENKINS-18578 ]
            danielbeck Daniel Beck added a comment - - edited

            IMO this could be resolved as duplicate of JENKINS-18578. A safe location should always be available in the slave home path...

            oleg_nenashev Oleg Nenashev added a comment -

            Caching sometimes leads to locked files (see JENKINS-20913).
            BTW, I don't see failures in newest core version => the priority can be decreased

            oleg_nenashev Oleg Nenashev made changes -
            Priority Critical [ 2 ] Minor [ 4 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 154273 ] JNJira + In-Review [ 178749 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Closing in favor of JENKINS-18578

            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Won't Do [ 10001 ]

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: