Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2219

upgrade from 1.4 to 1.8 causes a problem

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: svn-tag-plugin
    • Labels:
      None
    • Environment:
      Platform: PC, OS: Linux
    • Similar Issues:

      Description

      I upgraded my successfully running Hudson from svn_tag version 1.4 to svn_tag
      1.8, and then ran my simplest job (single repository, existing tree in
      "last_successful" tag directory). It ran, but when it went to create the new
      tag, it had this error:

      moduleLocation: Remote ->http://svn/svn/trunk/apollo12/res
      Failed to parse tag base URL 'http://svn/svn/tags/last-successful/res'. svn: URL
      'http://svn/svn/tags/last-successful/res/..' contains .. element
      Delete old tag http://svn/svn/tags/last-successful/res.
      FATAL: null
      java.lang.NullPointerException
      at
      org.tmatesoft.svn.core.wc.DefaultSVNRepositoryPool.createRepository(DefaultSVNRepositoryPool.java:210)
      at
      org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:297)
      at
      org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:289)
      at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:479)
      at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:464)
      at org.tmatesoft.svn.core.wc.SVNCommitClient.doImport(SVNCommitClient.java:430)
      at hudson.plugins.svn_tag.SvnTagPlugin.perform(SvnTagPlugin.java:209)
      at hudson.plugins.svn_tag.SvnTagPublisher.perform(SvnTagPublisher.java:79)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:309)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:297)
      at hudson.model.Build$RunnerImpl.cleanUp(Build.java:127)
      at hudson.model.Run.run(Run.java:823)
      at hudson.model.Build.run(Build.java:84)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)

      It did delete the existing directory under tags, but failed to create a new one.
      I didn't do any reconfiguring of the job - I only updated the svn_tag plugin
      version (so the "Tag Base URL" is unchanged at
      "http://svn/svn/tags/last-successful/res")

      Thanks for your efforts!

        Attachments

          Activity

          dani_ dani_ created issue -
          k2nakamura k2nakamura made changes -
          Field Original Value New Value
          Status Open [ 1 ] In Progress [ 3 ]
          k2nakamura k2nakamura made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          mikenereson mikenereson made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          mikenereson mikenereson made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          abayer Andrew Bayer made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 132292 ] JNJira + In-Review [ 201297 ]

            People

            • Assignee:
              k2nakamura k2nakamura
              Reporter:
              dani_ dani_
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: