Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22211

Parallel stages display distorted

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Job flow set up to have parallel stages displays as a distorted flow, regardless of browser (FF or Chrome) or browser window size. The JIRA form won't let me specify the exact version I'm using, but it's 0.7.1 (the latest, I believe).

        Attachments

          Activity

          craftsman Roy Miller created issue -
          patbos Patrik Boström made changes -
          Field Original Value New Value
          Assignee Patrik Boström [ patbos ]
          patbos Patrik Boström added a comment -

          I cant reproduce this issue. Is it possible to send the config.xml for the jobs? Either attach them to the Jira or send it to me via email.

          johanbloemberg Johan Bloemberg added a comment -

          We experience the same issue with our pipeline. Version 0.7.1. Using trigger parameterized build if that would make a difference.

          johanbloemberg Johan Bloemberg made changes -
          patbos Patrik Boström added a comment -

          I managed to reproduce the problem now. Working on a fix.

          patbos Patrik Boström made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          patbos Patrik Boström made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          patbos Patrik Boström added a comment -

          Released in 0.7.2

          patbos Patrik Boström made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          craftsman Roy Miller added a comment -

          Thanks, Patrik. I sent you a couple emails with lots of details about how to reproduce the bug, but I'm not sure if you got them. I replace to the emails I got when you made comments on this Jenkins ticket. The email address for you looked legit.

          Glad this is fixed. Does it a take a little while for Jenkins to tell me there's an update for the plugin to version 0.7.2? I haven't seen the "upgrades available" message yet.

          patbos Patrik Boström added a comment -

          It usually takes a couple of hour until Jenkins picks up new plugin releases, but you should be able to see the new version by now. I hope that my fix has resolved the issue. Please report back the result.

          johanbloemberg Johan Bloemberg added a comment -

          Hi Patrik, thx, installed it yesterday as soon as it was available. Didn't have to wait long. Looks much better There is still a minor glitch but not as big as the previous one: http://auth-83051f68-ec6c-44e0-afe5-bd8902acff57.cdn.spilcloud.com/10/1395214255_Screen_Shot_2014-03-19_at_08.29.18.png

          patbos Patrik Boström added a comment -

          Thanks for the feedback Johan. What browser are you using?

          johanbloemberg Johan Bloemberg added a comment -

          Chrome Version 33.0.1750.152, OSX.

          I just noticed i have two projects with similar workflow, one having this issue the other not. I will try to find the difference and report back here.

          patbos Patrik Boström added a comment -

          Johan, it is because of the longer stage name "OOSS-create-version". We need to handle longer stage name in a better way in the plugin.

          johanbloemberg Johan Bloemberg added a comment -

          Yes, the other project has a shorter stage name.

          patbos Patrik Boström added a comment -

          Johan, I have created JENKINS-22327 for the long stage name bug.

          pmatignon Patrice Matignon added a comment -

          This is still not working for me, with version 0.7.2.
          I have multiple pipelines representing multiple maintenance branches of the same codebase, and each pipeline has the same stage names and step names. They are all using different projects though (all projects are duplicated for each branch/pipeline).
          What happens is that the top pipeline has the proper arrows in the view, and the bottom one has all the arrows from the first stage going all the way up to the second stage of the top pipeline (the remaining stages on the bottom pipeline just aren't part of the graph). All pipelines in between the top and bottom ones have no arrow/lines.
          If I add a completely different pipeline at the bottom, then it won't have any lines/arrows at all, but it won't point t the top pipeline, so I think it's related to the fact that I'm using the same stage/step names.
          This is a regression, it was working fine before version 0.7.1 (which had only the top pipeline displayed)

          pmatignon Patrice Matignon added a comment -

          Then again, I have no parallel stages, so this is not the proper JIRA, my apologies

          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 154291 ] JNJira + In-Review [ 207519 ]

            People

            • Assignee:
              patbos Patrik Boström
              Reporter:
              craftsman Roy Miller
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: