Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22275

Save of job configuration doesn't work after removing a parameter under 'This build is parameterized'

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.554
      Chrome 33
    • Similar Issues:

      Description

      Situation: Having a job with two Parameters set in section 'This build is parameterized'.

      Issue: After removing a parameter (it doesn't matter what kind), hitting the Save button for saving the job configuration does not do anything.

      Steps to reproduce:

      1. Create a new free style job
      2. Tick the box before 'This build is parameterized'
      3. Add two parameters, e.g.
        1. Choice Parameter
        2. Boolean Parameter
      4. Save the configuration
      5. Re-open the configuration
      6. Click on the 'Delete' button of the Boolean Parameter under the 'This build is parameterized' section
        • Now you will see that nothing happens

        Attachments

          Issue Links

            Activity

            ikedam ikedam added a comment -

            Looks a issue of Jenkins core, not parameterized-trigger.
            Changed component/s.

            jccheng Jeff Cheng added a comment -

            Seems to be an issue with Chrome. With IE and Firefox, I am able to save after removing a parameter.

            wbauer wbauer added a comment -

            Same issue here with Chrome 34.0.1847.45 and Safari 7.0.3 (9537.75.14).
            It works fine in Firefox 25.0.

            danielbeck Daniel Beck added a comment -

            In step 5, are you reloading the page, or navigating away, then clicking on the 'Configure' link in the sidebar?

            Is there a step 6 "Click on Save or Apply" missing in your description?

            Are there any JavaScript errors?

            Are you trying to click the buttons with the mouse, or do you give them keyboard focus and trigger them by e.g. pressing Space?

            Which browsers (+versions) work, which are affected by this issue? Which is the last known good Jenkins version?

            Any watchers: Feel free to contribute information here.

            If you have a public, affected Jenkins and could open up one job's config page for me (in private, send email) that would be great.


            Unfortunately, there's a lot of conflicting information about this – and we haven't even looked at plugins possibly breaking the job config page. FWIW, I cannot reproduce it in Firefox 29, Safari 7, or Chrome 34 on OS X with 1.559 or 1.561.

            danielbeck Daniel Beck added a comment -

            JENKINS-22582 looks a lot like this, and is fixed in 1.560. Can anyone confirm whether this issue is also fixed?

            danielbeck Daniel Beck added a comment -

            Let's assume this duplicates JENKINS-22582 and is fixed in 1.560. This issue can always be reopened, or a new issue can be filed, if this still happens in 1.560+.

            (Please file a new issue if it happens in versions much newer than 1.560, say 1.580 or higher given that it might be an unrelated issue with the same symptoms)

            erik_purins Erik Purins added a comment - - edited

            Although this has been resolved as dupe, I am seeing this in 1.556 (linked bug 22582 is assumed the dupe, but was fixed 1.554). The behavior I see occurs in Safari and Opera on mac, and the behavior described (removing a defined parameter) is one instance that can cause this.

            I see a javascript warning in opera, 'event.returnValue is deprecated. Please use the standard event.preventDefault() instead.'

            ikedam ikedam added a comment -

            I cannot get your point.
            As @danielbeck said, JENKINS-22582 is fixed in 1.560.
            And it's not strange Jenkins 1.556 is still affected by that problem.
            What tells you JENKINS-21582 is fixed in 1.554?

            danielbeck Daniel Beck added a comment - - edited

            Erik: The label '1.554.2-fixed' on the linked issue means that the fix was backported to the current line of stable Jenkins releases.

            As you can see from the commit linked in the linked issue's comments, it was first included in 1.560.

            erik_purins Erik Purins added a comment -

            Thanks Daniel for explaining the backport tag; ikedam, I read the backport tag and assumed that meant the issue was claimed fixed in earlier version, which is why I mentioned my issue.

            outspoken Ken Garland added a comment -

            Looks like this issue is back with 1.569

            danielbeck Daniel Beck added a comment -

            Ken Garland: Is that a typo, or are you referring to a >6 months old release?

            outspoken Ken Garland added a comment - - edited

            Typo... Jenkins ver. 1.596

            I can get it to work in Safari but Chrome (even Chrome Canary) doesn't work.

            danielbeck Daniel Beck added a comment -

            Cannot reproduce the issue on a pristine instance of 1.596 with Chrome 39, therefore resolving again. Note that nightly, alpha, beta, or Canary versions of browsers are not supported, see https://wiki.jenkins-ci.org/display/JENKINS/Browser+Compatibility+Matrix

            Please read https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue and file a new issue that can be investigated independently from this one (i.e. let's not spam the watchers), as the problem you're experiencing seems to only occur on some circumstances.


              People

              • Assignee:
                Unassigned
                Reporter:
                johanh Johan H
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: