Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22462

can't download jdk from oracle site

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Oracle has change the cookie required to detect licence agreement.
      So Jenkins can't download jdk package from http://download.oracle.com/otn/java.
      The cookie must be : "oraclelicense=accept-securebackup-cookie; domain=.oracle.com; path=/; expires=-1"

        Attachments

          Issue Links

            Activity

            gboucherie Guillaume Boucherie added a comment -

            I create a pull request for this : https://github.com/jenkinsci/jenkins/pull/1171

            jglick Jesse Glick added a comment -

            Did you already try with the fix of JENKINS-22347? Because that worked for me yesterday (or maybe it was the day before).

            gboucherie Guillaume Boucherie added a comment -

            Thanks for the link.
            But I don't think its related to JDK8 because download of older jdk7 version failed on 1.532.2

            jglick Jesse Glick added a comment -

            Despite the title I think this may have related to all JDK versions. So please try a build with the fix of that issue. I suspect this is just a duplicate.

            gboucherie Guillaume Boucherie added a comment -

            Its clearly a duplicate of JENKINS-22347.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Guillaume Boucherie
            Path:
            core/src/main/java/hudson/tools/JDKInstaller.java
            http://jenkins-ci.org/commit/jenkins/ef22ba2e568e820750fa977683fa2c862be35eb4
            Log:
            JENKINS-22462 update cookie name and value

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            core/src/main/java/hudson/tools/JDKInstaller.java
            http://jenkins-ci.org/commit/jenkins/d67600e7d70e0f6bb1e12054b5b4aba26bd581e0
            Log:
            Merge pull request #1171 from gboucherie/JENKINS-22462

            JENKINS-22462 update cookie name and value

            Compare: https://github.com/jenkinsci/jenkins/compare/9313b5f6b746...d67600e7d70e


              People

              • Assignee:
                Unassigned
                Reporter:
                gboucherie Guillaume Boucherie
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: