Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22568

Subversion polling not work when Repository URL value is variable - E125002: Malformed URL '${SVN_REPO_VARIABLE}'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      CentOS 6 64bit master

      Jenkins ver. 1.558

      subversion plugin: 2.2
      credentials plugin: 1.10
    • Similar Issues:

      Description

      When I set Repository URL as variable instead of direct url(please see attachment), polling is not working. Checkout and update are working fine.

      Apr 10, 2014 10:03:17 AM hudson.scm.SubversionSCM$DescriptorImpl doCheckRevisionPropertiesSupported
      INFO: Failed to access subversion repository ${SVN_REPO}
      org.tmatesoft.svn.core.SVNException: svn: E125002: Malformed URL '${SVN_REPO}'
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.SVNURL.<init>(SVNURL.java:233)
      at org.tmatesoft.svn.core.SVNURL.parseURIDecoded(SVNURL.java:115)
      at hudson.scm.SubversionSCM$DescriptorImpl.doCheckRevisionPropertiesSupported(SubversionSCM.java:2185)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at org.kohsuke.stapler.Function$InstanceFunction.invoke(Function.java:298)

      at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1011)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
      at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:668)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)
      at winstone.BoundedExecutorService$1.run(BoundedExecutorService.java:77)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:724)
      Caused by: svn: E125002: Malformed URL '${SVN_REPO}'
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:171)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:126)
      at org.tmatesoft.svn.core.SVNURL.<init>(SVNURL.java:232)
      ... 94 more

        Attachments

          Issue Links

            Activity

            recena Manuel Recena Soto added a comment -

            @chris_mh3,

            I received feedback from several users confirming that this bug is solved. I prefer to close this issue and open new one with new information.

            Regards,

            chris_mh3 chris_mh3 added a comment - - edited

            the branch variable is defined in Manage Jenkins -> Configure System -> Global properties -> Environment variables

            recena Manuel Recena Soto added a comment -

            chris_mh3 Could you add a new ticket, please?

            chris_mh3 chris_mh3 added a comment -
            recena Manuel Recena Soto added a comment -

            chris_mh3, Thank you.


              People

              • Assignee:
                recena Manuel Recena Soto
                Reporter:
                dilyin Denis Ilyin
              • Votes:
                5 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: