Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22813

Warning when clean install and restart

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: gerrit-trigger-plugin
    • Labels:
      None
    • Environment:
      JRE 1.7
      Jenkins stable(1.532.3), Latest(1.561), Requred(1.509.3)
      Gerrit Trigger 2.12-beta-1
    • Similar Issues:

      Description

      Step

      1. Download jenkins.war from official site
      2. Download http://repo.jenkins-ci.org/public/com/sonyericsson/hudson/plugins/gerrit/gerrit-trigger/2.12.0-beta-1/gerrit-trigger-2.12.0-beta-1.hpi
      2. Remove ~/.jenkins/
      3. $ java -jar jenkins.war
      4. Open http://localhost:8080/
      5. Enter Manage Jenkins > Manage Plugins
      6. Switch to Advanced tab
      7. In Upload Plugin section, select downloaded plugin file then click Upload
      8. Restart Jenkins from CLI.

      Issue

      The below warning is shown in install phase.

      Apr 30, 2014 10:31:09 AM hudson.ExtensionFinder$Sezpoz _find
      WARNING: Failed to load com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:628)
      	at hudson.ExtensionFinder$Sezpoz.access$800(ExtensionFinder.java:555)
      	at hudson.ExtensionFinder$Sezpoz$1.find(ExtensionFinder.java:599)
      	at hudson.ExtensionFinder$GuiceFinder.refresh(ExtensionFinder.java:331)
      	at jenkins.model.Jenkins.refreshExtensions(Jenkins.java:2158)
      	at hudson.PluginManager.dynamicLoad(PluginManager.java:433)
      	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1304)
      	at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1107)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:104)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 12 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 28 more
      
      Apr 30, 2014 10:31:09 AM hudson.ExtensionFinder$GuiceFinder$SezpozModule configure
      WARNING: Failed to load com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:504)
      	at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
      	at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:230)
      	at com.google.inject.spi.Elements.getElements(Elements.java:103)
      	at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:136)
      	at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
      	at com.google.inject.internal.InjectorImpl.createChildInjector(InjectorImpl.java:230)
      	at hudson.ExtensionFinder$GuiceFinder.refresh(ExtensionFinder.java:336)
      	at jenkins.model.Jenkins.refreshExtensions(Jenkins.java:2158)
      	at hudson.PluginManager.dynamicLoad(PluginManager.java:433)
      	at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1304)
      	at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1107)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      	at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:104)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor6.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 16 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 32 more
      

      The below warning is shown in restart phase.

      Apr 30, 2014 10:32:40 AM hudson.ExtensionFinder$Sezpoz scout
      WARNING: Failed to scout com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:666)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:311)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.iterator(ExtensionList.java:138)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:310)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.size(ExtensionList.java:157)
      	at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.postInitialize(PluginImpl.java:289)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:376)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 19 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 35 more
      
      Apr 30, 2014 10:32:40 AM hudson.ExtensionFinder$Sezpoz _find
      WARNING: Failed to load com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:628)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      	at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:259)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
      	at java.lang.Class.newInstance(Class.java:374)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:642)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:151)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:317)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.iterator(ExtensionList.java:138)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:310)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.size(ExtensionList.java:157)
      	at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.postInitialize(PluginImpl.java:289)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:376)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 30 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 46 more
      
      Apr 30, 2014 10:32:40 AM hudson.ExtensionFinder$Sezpoz _find
      WARNING: Failed to load com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:628)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      	at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:277)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
      	at java.lang.Class.newInstance(Class.java:374)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:642)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:151)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:317)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.iterator(ExtensionList.java:138)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:310)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.size(ExtensionList.java:157)
      	at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.postInitialize(PluginImpl.java:289)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:376)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 30 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 46 more
      
      Apr 30, 2014 10:32:40 AM hudson.ExtensionFinder$GuiceFinder$SezpozModule configure
      WARNING: Failed to load com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$GuiceFinder$SezpozModule.configure(ExtensionFinder.java:504)
      	at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
      	at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:230)
      	at com.google.inject.spi.Elements.getElements(Elements.java:103)
      	at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:136)
      	at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
      	at com.google.inject.Guice.createInjector(Guice.java:96)
      	at com.google.inject.Guice.createInjector(Guice.java:73)
      	at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:282)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
      	at java.lang.Class.newInstance(Class.java:374)
      	at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:642)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:151)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:317)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.iterator(ExtensionList.java:138)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:310)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.size(ExtensionList.java:157)
      	at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.postInitialize(PluginImpl.java:289)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:376)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 36 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 52 more
      
      Apr 30, 2014 10:32:40 AM hudson.ExtensionFinder$Sezpoz _find
      WARNING: Failed to load com.sonyericsson.hudson.plugins.gerrit.trigger.hudsontrigger.GerritTriggerBuildChooser$DescriptorImpl
      java.lang.InstantiationException: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      	at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:628)
      	at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:617)
      	at hudson.ExtensionFinder._find(ExtensionFinder.java:151)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:317)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.iterator(ExtensionList.java:138)
      	at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:310)
      	at hudson.ExtensionList.load(ExtensionList.java:295)
      	at hudson.ExtensionList.ensureLoaded(ExtensionList.java:248)
      	at hudson.ExtensionList.size(ExtensionList.java:157)
      	at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.postInitialize(PluginImpl.java:289)
      	at hudson.PluginManager$2$1$2.run(PluginManager.java:376)
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.NoClassDefFoundError: hudson/plugins/git/util/BuildChooserDescriptor
      	at java.lang.ClassLoader.defineClass1(Native Method)
      	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
      	at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      	at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:731)
      	at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      	at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      	at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1029)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      	... 21 more
      Caused by: java.lang.ClassNotFoundException: hudson.plugins.git.util.BuildChooserDescriptor
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
      	... 37 more
      

      I guess git plugin or git-client plugin is not optional but required.

        Attachments

          Activity

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: rinrinne
          Path:
          src/main/java/com/sonyericsson/hudson/plugins/gerrit/trigger/hudsontrigger/GerritTriggerBuildChooser.java
          http://jenkins-ci.org/commit/gerrit-trigger-plugin/ec0dd54750d0e236f88b3b3cbf2d9f1071a1571c
          Log:
          Set optional flag to GerritTriggerBuildChooser extension.

          Git plugin is optional, So any loading error should not be logged.

          Fix for JENKINS-22813: Warning when clean install and restart
          https://issues.jenkins-ci.org/browse/JENKINS-22813


            People

            • Assignee:
              rsandell rsandell
              Reporter:
              rin_ne rin_ne
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: