Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2288

p4Web no longer works / saves to project config.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When I upgraded (currently to version 1.248) I lost the ability to browse
      repositories....
      The project configuration keeps defaulting to auto after being saved.
      I went in and manually added back the section to the "jobs" config.xml

      <browser class="hudson.plugins.perforce.browsers.P4Web">
      <url>http://builds:5000/</url>
      <p4WebBegShite>@md=d&rc=s&rt=s&thb=y&c=ihy@</p4WebBegShite>
      <p4WebEndShite>?ac=22</p4WebEndShite>
      <p4DifEndShite>?ac=19&</p4DifEndShite>
      </browser>

      And the job disappeared until I removed the section from the config.xml

        Attachments

          Issue Links

            Activity

            brucepainter brucepainter added a comment -

            I can confirm this is still an issue in version 1.259 with plugin version 1.0.12

            kohsuke Kohsuke Kawaguchi added a comment -

            Un-assigning this from digerata per request by him.

            toddhicks toddhicks added a comment -

            This issues appears to be FIXED in the latest builds (1.282 -> ).

            brucepainter brucepainter added a comment -

            I am currently using Hudson 1.284 with Perforce plugin version 1.0.12 and am
            still seeing the issue.

            I had been told this was fixed in the latest updates to the Perforce plugin,
            which hasn't been released since 05/2008.

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 2613 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -

            Fixed in 1.0.13.


              People

              • Assignee:
                Unassigned
                Reporter:
                toddhicks toddhicks
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: