Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Component/s: core
    • Labels:
      None
    • Environment:
      GUI and objects name
    • Similar Issues:

      Description

      I have problems with some objects name that have Latin characters(ñ), these objects are taken from versionador Gitlab and after each merge that generates the gitlab packaging (jar) using gradle which has incorrect characters. I tried to put a encoding in the gradle code but not solved since the Jenkins workspace already cloned the error.

        Attachments

          Issue Links

            Activity

            Hide
            danielbeck Daniel Beck added a comment -

            What happens when you run git from an interactive shell, does the same issue occur then? What's the locale (e.g. LANG environment variable on Linux) in an interactive shell? What's the charset of the Jenkins slave (select the node in Jenkins, then System Information)

            Show
            danielbeck Daniel Beck added a comment - What happens when you run git from an interactive shell, does the same issue occur then? What's the locale (e.g. LANG environment variable on Linux) in an interactive shell? What's the charset of the Jenkins slave (select the node in Jenkins, then System Information)
            Hide
            andres123 Andres Garcia added a comment - - edited

            The only tool I use is OpenGrok and does not present the same error. The locale LANG environment variable on Linux is en_US.ISO-8859-15.

            Show
            andres123 Andres Garcia added a comment - - edited The only tool I use is OpenGrok and does not present the same error. The locale LANG environment variable on Linux is en_US.ISO-8859-15.
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Seems to be a core issue or slave plugin issue. BTW, I have no idea how to create a reproducible scenario.

            @Andres
            What slave type do you use?
            Please also provide the system information (see https://wiki.jenkins-ci.org/display/JENKINS/Issue+Tracking#IssueTracking-Whattoputinthedescriptionofanissuereport%3F)

            Show
            oleg_nenashev Oleg Nenashev added a comment - Seems to be a core issue or slave plugin issue. BTW, I have no idea how to create a reproducible scenario. @Andres What slave type do you use? Please also provide the system information (see https://wiki.jenkins-ci.org/display/JENKINS/Issue+Tracking#IssueTracking-Whattoputinthedescriptionofanissuereport%3F )
            Hide
            danielbeck Daniel Beck added a comment - - edited

            Please run System.getProperty('file.encoding') in Manage Jenkins » Script Console and Manage Jenkins » Manage Nodes » (executing slave) » Script Console and provide output of both.

            Show
            danielbeck Daniel Beck added a comment - - edited Please run System.getProperty('file.encoding') in Manage Jenkins » Script Console and Manage Jenkins » Manage Nodes » (executing slave) » Script Console and provide output of both.

              People

              • Assignee:
                Unassigned
                Reporter:
                andres123 Andres Garcia
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated: