Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23200

Jackson exception when parsing the result of a Docker command.

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      I am using CentOS 6.4 64bit with Docker version 0.11.1, build fb99f99/0.11.1 and version 1.3 of Docker build step plugin.
    • Similar Issues:

      Description

      I am trying to use the Docker build step plugin to launch an instance of CouchDB running inside a Docker container.

      A Jackson exception occurs after the container is launched. Note that the container itself is launched properly.

      See the output from Jenkins below:

      Started by user anonymous
      Building in workspace /var/lib/jenkins/jobs/couchdb-launcher/workspace
      [Docker] INFO: created container id 3d1110bcc22903a599d11c563221d8acbaa98e1dcf3b735c328dde002bb38439 (from image clouchdb)
      FATAL: org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field "ExecDriver" (Class com.kpelykh.docker.client.model.ContainerInspectResponse), not marked as ignorable
      at [Source: com.sun.jersey.client.apache4.ApacheHttpClient4Handler$HttpClientResponseInputStream@127df275; line: 1, column: 1069] (through reference chain: com.kpelykh.docker.client.model.ContainerInspectResponse["ExecDriver"])
      com.sun.jersey.api.client.ClientHandlerException: org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field "ExecDriver" (Class com.kpelykh.docker.client.model.ContainerInspectResponse), not marked as ignorable
      at [Source: com.sun.jersey.client.apache4.ApacheHttpClient4Handler$HttpClientResponseInputStream@127df275; line: 1, column: 1069] (through reference chain: com.kpelykh.docker.client.model.ContainerInspectResponse["ExecDriver"])
      at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:644)
      at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:586)
      at com.sun.jersey.api.client.WebResource.handle(WebResource.java:686)
      at com.sun.jersey.api.client.WebResource.access$200(WebResource.java:74)
      at com.sun.jersey.api.client.WebResource$Builder.get(WebResource.java:509)
      at com.kpelykh.docker.client.DockerClient.inspectContainer(DockerClient.java:418)
      at org.jenkinsci.plugins.dockerbuildstep.cmd.CreateContainerCommand.execute(CreateContainerCommand.java:74)
      at org.jenkinsci.plugins.dockerbuildstep.DockerBuilder.perform(DockerBuilder.java:57)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:745)
      at hudson.model.Build$BuildExecution.build(Build.java:198)
      at hudson.model.Build$BuildExecution.doRun(Build.java:159)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:518)
      at hudson.model.Run.execute(Run.java:1706)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:231)
      Caused by: org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field "ExecDriver" (Class com.kpelykh.docker.client.model.ContainerInspectResponse), not marked as ignorable
      at [Source: com.sun.jersey.client.apache4.ApacheHttpClient4Handler$HttpClientResponseInputStream@127df275; line: 1, column: 1069] (through reference chain: com.kpelykh.docker.client.model.ContainerInspectResponse["ExecDriver"])
      at org.codehaus.jackson.map.exc.UnrecognizedPropertyException.from(UnrecognizedPropertyException.java:53)
      at org.codehaus.jackson.map.deser.StdDeserializationContext.unknownFieldException(StdDeserializationContext.java:267)
      at org.codehaus.jackson.map.deser.std.StdDeserializer.reportUnknownProperty(StdDeserializer.java:649)
      at org.codehaus.jackson.map.deser.std.StdDeserializer.handleUnknownProperty(StdDeserializer.java:635)
      at org.codehaus.jackson.map.deser.BeanDeserializer.handleUnknownProperty(BeanDeserializer.java:1355)
      at org.codehaus.jackson.map.deser.BeanDeserializer.deserializeFromObject(BeanDeserializer.java:717)
      at org.codehaus.jackson.map.deser.BeanDeserializer.deserialize(BeanDeserializer.java:580)
      at org.codehaus.jackson.map.ObjectMapper._readValue(ObjectMapper.java:2695)
      at org.codehaus.jackson.map.ObjectMapper.readValue(ObjectMapper.java:1308)
      at org.codehaus.jackson.jaxrs.JacksonJsonProvider.readFrom(JacksonJsonProvider.java:419)
      at com.sun.jersey.json.impl.provider.entity.JacksonProviderProxy.readFrom(JacksonProviderProxy.java:139)
      at com.sun.jersey.api.client.ClientResponse.getEntity(ClientResponse.java:634)
      ... 16 more

        Attachments

          Activity

          vjuranek vjuranek added a comment -

          Hi, unfortunately plugin currently supports only Docker 0.8 as underlying docker-java library supports also only docker 0.8. I'll check the current status and eventually try to build the plugin against docker-java snapshot (see also JENKINS-22985 for more details about docker-java library issues).

          kafecho Guillaume Belrose added a comment -

          Ok thanks for the update. For the time being I can just revert to using Docker 0.8.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Vojtech Juranek
          Path:
          pom.xml
          src/main/java/org/jenkinsci/plugins/dockerbuildstep/DockerBuilder.java
          http://jenkins-ci.org/commit/docker-build-step-plugin/34080f9912cd94dc69903d1f24257eb336c84f09
          Log:
          [FIXED JENKINS-23200] Upgrade to the lates docker-java

          To cover latest Docker 1.11 REST API


            People

            • Assignee:
              vjuranek vjuranek
              Reporter:
              kafecho Guillaume Belrose
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: