Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23213

Mac Slave terminated unexpectedly every few minutes

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: ssh-slaves-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      ERROR: Connection terminated
      java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
      Caused by: java.io.EOFException
      	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2325)
      	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2794)
      	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:801)
      	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
      	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
      	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
      ERROR: [05/28/14 07:05:39] slave agent was terminated
      java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
      Caused by: java.io.EOFException
      	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2325)
      	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2794)
      	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:801)
      	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
      	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
      	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
      

        Attachments

          Activity

          eranchetz Eran Chetzroni created issue -
          eranchetz Eran Chetzroni made changes -
          Field Original Value New Value
          Environment 13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
          Mac 10.9.2
          java version "1.8.0_05"
          Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
          13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
          Mac 10.9.2
          java version "1.8.0_05"
          Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
          Jenkins ver. 1.564
          eranchetz Eran Chetzroni made changes -
          Environment 13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
          Mac 10.9.2
          java version "1.8.0_05"
          Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
          Jenkins ver. 1.564
          13.1.0 Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
          Mac 10.9.2
          java version "1.8.0_05"
          Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
          Jenkins ver. 1.564 also on 1.565
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 155770 ] JNJira + In-Review [ 179115 ]
          ifernandezcalvo Ivan Fernandez Calvo added a comment -

          We will increase log level and enable remoting logs to be able to diagnose this kind of issues.

          ifernandezcalvo Ivan Fernandez Calvo made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Kohsuke Kawaguchi [ kohsuke ] Ivan Fernandez Calvo [ ifernandezcalvo ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              ifernandezcalvo Ivan Fernandez Calvo
              Reporter:
              eranchetz Eran Chetzroni
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: