Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23316

Some projects have builds whose timestamps are inconsistent

    Details

    • Similar Issues:

      Description

      Constantly get "Some projects have builds whose timestamps are inconsistent" for all jobs, all builds. Throwing away all build data and starting over, everything works fine again for a while, but soon (about a day) everything reports as "Some projects have builds whose timestamps are inconsistent" again and Jenkins wants me to dump all history to fix it.

      In addition, and probably related, "Last Success"/"Last Failure" data is always wrong or N/A. An individual build from an individual jobs data will be shown across all jobs. Refresh then all jobs say N/A instead. After a long time I can visit Jenkins and everything looks right... but hit refresh and all says N/A immediately again.

      Also, again related to the same issue I'm betting, build history in the left nav for each job sometimes links to a completely unrelated build history page for a different job.

      Again, related, restarting the Jenkins Windows Service, all jobs come up with no status, all sunny/successful, or all failed/rainy... even though in reality there is a mix. All FxCop/StyleCop/Test Results, etc. no longer display.

      I have tried Jenkins version 1.554.1 up through 1.566, all exhibit these issues. I've researched this on Google and see others experiencing this issue all the way back since 1.480+. The only version I can say with confidence that doesn't have these issues is 1.449, as I worked with a company on this version for some time and never saw these issues once.

      Is this simply a Windows 2012 R2 unsupported issue? Or has Jenkins really been a complete mess for the last 100+ versions?

        Attachments

          Issue Links

            Activity

            Hide
            leedega Kevin Phillips added a comment -

            I see this issue has been resolved as a duplicate, but there is no link or mention of which issue it duplicates?

            We are encountering this exact problem on the last two LTS editions of Jenkins (1.596.3 and 1.609.1). I'd like to make sure any further debugging information I report is put in the correct location.

            Show
            leedega Kevin Phillips added a comment - I see this issue has been resolved as a duplicate, but there is no link or mention of which issue it duplicates? We are encountering this exact problem on the last two LTS editions of Jenkins (1.596.3 and 1.609.1). I'd like to make sure any further debugging information I report is put in the correct location.

              People

              • Assignee:
                Unassigned
                Reporter:
                cosborn Clay Osborn
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: