Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23384

Stopping a jenkins clients marks many *other* clients as 'offline' in jenkins master

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      On Windows, for jenkins the last known point where we know this not to be a problem is 1.544, but recent builds such as 1.566 demonstrate this fault.
    • Similar Issues:

      Description

      It seems that when we manually restart a jenkins slave agent running on a windows client, a bunch of our other slaves were marked as permanently offline by jenkins (master).

      Potentially we had mixed slave versions (2.33 + 2.42) if that's relevant ? (Notably clients running a 2.14 as a service appear un-affected ?)

      The system log contained the following errors after we manually restarted the jenkins slave on DEV-CI-SE-16:

      un 10, 2014 10:55:51 AM WARNING org.jenkinsci.remoting.nio.NioChannelHub run
      Communication problem
      java.io.IOException: Connection reset by peer
      	at sun.nio.ch.FileDispatcher.read0(Native Method)
      	at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:39)
      	at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java:251)
      	at sun.nio.ch.IOUtil.read(IOUtil.java:224)
      	at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:254)
      	at org.jenkinsci.remoting.nio.FifoBuffer$Pointer.receive(FifoBuffer.java:136)
      	at org.jenkinsci.remoting.nio.FifoBuffer.receive(FifoBuffer.java:306)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:496)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-16 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:563)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.io.IOException: Connection reset by peer
      	at sun.nio.ch.FileDispatcher.read0(Native Method)
      	at sun.nio.ch.SocketDispatcher.read(SocketDispatcher.java:39)
      	at sun.nio.ch.IOUtil.readIntoNativeBuffer(IOUtil.java:251)
      	at sun.nio.ch.IOUtil.read(IOUtil.java:224)
      	at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:254)
      	at org.jenkinsci.remoting.nio.FifoBuffer$Pointer.receive(FifoBuffer.java:136)
      	at org.jenkinsci.remoting.nio.FifoBuffer.receive(FifoBuffer.java:306)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:496)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING org.jenkinsci.remoting.nio.NioChannelHub run
      Failed to select
      java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-12 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-08 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-13 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-09 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-10 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-14 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-15 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-11 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      
      Jun 10, 2014 10:55:51 AM WARNING jenkins.slaves.JnlpSlaveAgentProtocol$Handler$1 onClosed
      NioChannelHub keys=9 gen=23306: Computer.threadPoolForRemoting [#2] for + DEV-CI-SE-16 terminated
      java.io.IOException: Failed to abort
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport.abort(NioChannelHub.java:184)
      	at org.jenkinsci.remoting.nio.NioChannelHub.abortAll(NioChannelHub.java:599)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:481)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)
      Caused by: java.nio.channels.ClosedChannelException
      	at sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:656)
      	at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:378)
      	at org.jenkinsci.remoting.nio.Closeables$1.close(Closeables.java:20)
      	at org.jenkinsci.remoting.nio.NioChannelHub$MonoNioTransport.closeR(NioChannelHub.java:289)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:226)
      	at org.jenkinsci.remoting.nio.NioChannelHub$NioTransport$1.call(NioChannelHub.java:224)
      	at org.jenkinsci.remoting.nio.NioChannelHub.run(NioChannelHub.java:474)
      	... 7 more
      

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-22714

            kgiloo kgiloo added a comment -

            Well i upgraded from jenkins 1.564 to 1.568 (slave 2.41 to 2.43) and i had exactly the same problem.
            One slave shutdown mess all the other ones.
            Disconnected slaves were not recognized anymore unless you kill jawaw.exe.

            Hence i wonder if you say this was supposed to be fixed in 1.568...

            Downgrade to 1.564 put things right.
            Any hint?


              People

              • Assignee:
                Unassigned
                Reporter:
                ciaranj ciaranj
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: