Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23417

AccessRestriction on SecurityListener methods

    Details

    • Similar Issues:

      Description

      SecurityListener.fire* methods have @Restricted(NoExternalUse.class) annotation making external security implementations like github-oauth-plugin unable to fire those events.

      I've made a pr here

      https://github.com/jenkinsci/jenkins/pull/1277

        Attachments

          Activity

          surya548 surya gaddipati created issue -
          jglick Jesse Glick made changes -
          Field Original Value New Value
          Labels jenkins api lts-candidate security
          jglick Jesse Glick made changes -
          Component/s core [ 15593 ]
          Component/s security [ 15508 ]
          scm_issue_link SCM/JIRA link daemon made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          olivergondza Oliver Gond┼ża made changes -
          Labels api lts-candidate security 1.565.1-fixed api security
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 156041 ] JNJira + In-Review [ 195323 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              surya548 surya gaddipati
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: