Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23509

Go versions newer than 1.2.1 cannot be installed

    Details

    • Similar Issues:

      Description

      Any installations attempted from the new golang.org/dl/ site will fail (i.e. Go 1.2.2. Go 1.3 and newer).

      This is because the JSON contains a URL like "http://golang.org/dl/..." but this is actually an HTTP 302 redirect to somewhere else.

      Jenkins cannot handle HTTP 30x redirects when downloading tools automatically, so this fails — see JENKINS-23507.

      Until that is fixed, the temporary workaround should be to have the backend-crawler follow the redirects, so that Jenkins doesn't have to follow them.
      But this is fragile and not a good idea in general (i.e. we don't want to be breaking mirror networks etc.).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                orrc Christopher Orr
                Reporter:
                orrc Christopher Orr
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: