Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23575

Post-Build-Step "Publish Cppcheck results" not available in job generator project

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The post-build-step provided by the cppcheck plugin is not available in the "job generator" plugin.

        Attachments

          Activity

          dergruebel Lukas Goormann created issue -
          dergruebel Lukas Goormann made changes -
          Field Original Value New Value
          Description The post-build-step provided by the cppcheck plugin is not available in the job genereator plugin. The post-build-step provided by the cppcheck plugin is not available in the job generator plugin.
          dergruebel Lukas Goormann added a comment -

          Guess its not too difficult, but I have no experience in any Jenkins Plugin Programming...

          dergruebel Lukas Goormann made changes -
          Assignee Sylvain Benner [ syl20bnr ]
          dergruebel Lukas Goormann added a comment -

          After some research it is looking like a cppcheck plugin problem

          dergruebel Lukas Goormann made changes -
          Assignee Sylvain Benner [ syl20bnr ] Gregory Boissinot [ gbois ]
          Environment Jenkins 1.569, CppCheck Plugin 1.18 Jenkins 1.569, CppCheck Plugin 1.18, jobgenerator
          Description The post-build-step provided by the cppcheck plugin is not available in the job generator plugin. The post-build-step provided by the cppcheck plugin is not available in the "job generator" plugin.
          Component/s cppcheck [ 15693 ]
          Component/s jobgenerator [ 17435 ]
          maxk Max Krause made changes -
          mixalturek Michal Turek made changes -
          Assignee Gregory Boissinot [ gbois ] Michal Turek [ mixalturek ]
          mixalturek Michal Turek made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Michal Turek
          Path:
          pom.xml
          src/main/java/org/jenkinsci/plugins/cppcheck/CppcheckPublisher.java
          http://jenkins-ci.org/commit/cppcheck-plugin/b1662312bb370706732e79fef75d63941a49bdee
          Log:
          JENKINS-23575 Post-Build-Step "Publish Cppcheck results" not available in job generator project

          • isApplicable() returns true, to make Cppcheck publisher available in a whatever job type.
          • Dependencies to maven and ivy plugins removed.
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Michal Turek
          Path:
          .gitignore
          pom.xml
          src/main/java/com/thalesgroup/hudson/plugins/cppcheck/util/CppcheckUtil.java
          src/main/java/org/jenkinsci/plugins/cppcheck/CppcheckPublisher.java
          http://jenkins-ci.org/commit/cppcheck-plugin/b70bb5abc9ddccbea3ad19459f647f31fd6e77fa
          Log:
          Merge pull request #18 from mixalturek/master

          JENKINS-23575 Post-Build-Step "Publish Cppcheck results" not available in job generator project

          Compare: https://github.com/jenkinsci/cppcheck-plugin/compare/bbae9dfc10ff...b70bb5abc9dd

          mixalturek Michal Turek added a comment -

          Implemented, will be released in version 1.19.

          mixalturek Michal Turek made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Fix Version/s current [ 10162 ]
          Resolution Fixed [ 1 ]
          mixalturek Michal Turek made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          dergruebel Lukas Goormann added a comment -

          Hmmm progress made... can now find the "Publish CppCheck" step in the job-generator Postbuild menu, but clicking it does not have any visible effect...

          dergruebel Lukas Goormann made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          mixalturek Michal Turek added a comment -

          Hi Lukas,

          I have just tried to reproduce your issue, but it works for me with Jenkins 1.578, Cppcheck plugin 1.19, Job Generator plugin 1.22 and 64-bit Linux version of Chrome 37.

          I executed Jenkins using the command below and manually installed the plugins using the update center.

          mkdir -p home
          export JENKINS_HOME=home && java -jar jenkins.war
          

          I created Job Generator job template, added Cppcheck publisher there and configured it. Then I generated a new job using the generator, executed a built and verified the published Cppcheck data are available.

          I guess if there is any issue it will be in some JavaScript that comes directly from Jenkins. The plugin only provides a string to display in this menu, the real adding of publisher is done by Jenkins itself.

          • Did you try to refresh the configuration page and try again?
          • Did you try to add a different publisher using the same menu?
          • Did you try a different web browser?
          • Can you verify the issue is still present in the latest versions?

          M.

          dergruebel Lukas Goormann added a comment - - edited

          Hi Micheal,

          Thx for your reply. I veryfied the problem again, using Jenkins 1.578 and Cppcheck plugin 1.19, Job Generator plugin 1.22 on Win7 System.
          Browser is IE9 (update Version 9.0.30 )(due to Company Restrictions). Results:

          • Refresh Configuration Page as well as reloading Jenkins Configuration as well as Restarting Jenkins didn't help.
          • Other Publishers in Same menu are working fine.
          • Tried Portable Version of Firefox: Works! (-> IE9 Problem?)
          • Deletion of temp-Files of IE does not help either

          Additional: Collegue tried Manually build/installed Version of CppCheckPlugin (own build not through update center), also works.

          mixalturek Michal Turek added a comment -

          This is strange. Is the own build from the same sources and without any change (like different version of parent in Maven) and running under the same version of Jenkins in the same environment? I'm looking at JENKINS-14491 and JENKINS-14514, did you notice any error in Jenkins log or javascript console (if IE has anything like this) after clicking the button?

          As I said this looks more like Jenkins core issue than issue of this plugin, I'm only returning a string with "Publish Cppcheck results" in getDisplayName(). I have neither IE nor Windows so debugging from my side is impossible.

          mixalturek Michal Turek added a comment -

          The issue is related to a particular version of Jenkins core together with quite old version of IE so I'm closing this task for Cppcheck plugin. Please open a new Jenkins core task if you want to continue with any investigation.

          mixalturek Michal Turek made changes -
          Status Reopened [ 4 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          mixalturek Michal Turek made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 156356 ] JNJira + In-Review [ 207806 ]

            People

            • Assignee:
              mixalturek Michal Turek
              Reporter:
              dergruebel Lukas Goormann
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: