Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23621

Jenkins using out of date SVN library format 29

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Windows7
      Jenkins 1.568
      Latest cygwin.com install of "svn"
    • Similar Issues:

      Description

      1.568 using out of date SVN library format 29. Could I ask for Jenkins to be updated to use latest SVN library format for checkouts please?

      Latest cygwin.com "svn" package uses format 31, however Jenkins 1.568 is using out of date format 29

      This means that my job cannot update or commit files on the checkout made by Jenkins any more. (I am migrating from Hudson on older machine)

      svn: E155036: Please see the 'svn upgrade' command
      svn: E155036: The working copy at '/cygdrive/c/jenkins/shared_ws/sdk_build'
      is too old (format 29) to work with client version '1.8.9 (r1591380)' (expects format 31). You need to upgrade the working copy first.

        Attachments

          Issue Links

            Activity

            schristou Steven Christou added a comment -

            Duplicate of JENKINS-18935.

            javacody Cody Fyler added a comment -

            Same issue with latest TortoiseSVN...


              People

              • Assignee:
                schristou Steven Christou
                Reporter:
                jgrant Jonathan Grant
              • Votes:
                5 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: