Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23660

Attached log in Jenkins email incomplete

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: email-ext-plugin
    • Labels:
      None
    • Environment:
      Server SLES 11 SP2, client MAC OS X Mavericks
    • Similar Issues:

      Description

      I recently upgraded my Jenkins server from 1.559 to 1.570 and now the attached logs for the build jobs that run on the MAC are incomplete
      I had them attached as compressed file using the email-ext plugin, but with this version of Jenkins parts of the log are missing
      When attaching the uncompressed log I only get the first 2 MB of the log, which on the server has a size of about 14 MB
      Either the plugin has a problem or the log is not flushed out of memory before processing the post jobs.
      There are no error messages in the Jenkins log file
      The version of the email-ext plugin is 2.38.1
      For now I am not attaching the log file to my job emails so I have to click on the link in the email to check the output

        Attachments

          Issue Links

            Activity

            rkarbas Reinhard Karbas created issue -
            slide_o_mix Alex Earl added a comment -

            Email-ext is only built and tested against the LTS release,. Since you are using bleeding edge, you are almost guaranteed to have issues. This probably won't be looked at until the Jenkins release becomes LTS.

            rkarbas Reinhard Karbas added a comment -

            Please explain what LTS compared to bleeding edge means
            The version of Jenkins that I am using is officially released!

            slide_o_mix Alex Earl added a comment -

            LTS is Long Term Support, which is a more stable, tested version of Jenkins. Jenkins releases often and the latest versions will possibly have issues, especially with plugins that are developed against the LTS version. If there are changes in the core, then they will not be handled in email-ext until such a time as 1.570 (or something after it) becomes the new LTS release. The next LTS release will be based on 1.565 I believe.

            rkarbas Reinhard Karbas made changes -
            Field Original Value New Value
            Priority Minor [ 4 ] Major [ 3 ]
            Component/s core [ 15593 ]
            rkarbas Reinhard Karbas added a comment -

            The problem is not caused by the newer Jenkins version, but by a bug in the email-ext plugin
            I downgraded my plugin from 2.38.1 to 2.37.2.2 and the email is working correctly
            The log is zipped, attached and is complete
            The problem seems to happen when log files reach a certain size (2 MB?)

            slide_o_mix Alex Earl added a comment -

            Your initial description was incorrect then. You stated it was when you upgraded to a newer version of Jenkins that the issue started happening. It still could be a bug in core, they may have changed the way certain functions work to retrieve the log file. There was a change in 2.38.1 to how the log files were retrieved from core.

            rkarbas Reinhard Karbas added a comment -

            Sorry for that
            When I update my Jenkins version I normally also update all the plugins
            Fact is that it still works with the older version of the plugin (I have several builds now where the log is zipped and attached properly)
            However with the newer version of the plugin the functionality is broken

            slide_o_mix Alex Earl made changes -
            Link This issue is duplicated by JENKINS-23730 [ JENKINS-23730 ]
            danielbeck Daniel Beck added a comment - - edited

            Stapler's LargeText has been limited to 10k lines as of Jenkins 1.447.1.

            Which essentially is what's used by email-ext as build.getLogText().

            rkarbas Reinhard Karbas added a comment -

            This doesn't really make sense to me as I was using Jenkins 1.559 for a long time without ever having the problem
            It also still works with Jenkins 1.570 under the assumption of using the older version of the email-ext plugin
            My two biggest log files are 14K lines and 53K lines and the old version of the email-ext plugin can handle them without any problems
            However the new version of the email-ext plugin is broken and does not work correctly

            slide_o_mix Alex Earl added a comment -

            Yes, it will definitely have a problem with the change that Daniel mentions.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Alex Earl
            Path:
            src/main/java/hudson/plugins/emailext/AttachmentUtils.java
            http://jenkins-ci.org/commit/email-ext-plugin/bdece53fad4d1fd5d1c65b74e28e7150a5139b67
            Log:
            Fix JENKINS-23660

            slide_o_mix Alex Earl added a comment -

            Reworked how the log data source retrieves the log content from core to loop until the whole log is retrieved.

            slide_o_mix Alex Earl made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            slide_o_mix Alex Earl made changes -
            Link This issue is duplicated by JENKINS-24324 [ JENKINS-24324 ]
            rkarbas Reinhard Karbas added a comment -

            Which version of the plugin will contain this fix?

            slide_o_mix Alex Earl added a comment -

            It will be in 2.39

            rkarbas Reinhard Karbas added a comment -

            What's the planned release date for 2.39?

            slide_o_mix Alex Earl added a comment -

            When I can find enough time to complete testing and do a release.

            aml84 Antonio Mellado made changes -
            Assignee Alex Earl [ slide_o_mix ] Antonio Mellado [ aml84 ]
            aml84 Antonio Mellado made changes -
            Assignee Antonio Mellado [ aml84 ]
            slide_o_mix Alex Earl made changes -
            Assignee Alex Earl [ slide_o_mix ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 156444 ] JNJira + In-Review [ 195419 ]

              People

              • Assignee:
                slide_o_mix Alex Earl
                Reporter:
                rkarbas Reinhard Karbas
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: