Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2371

Slave build fails with FileNotFoundException

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Currently when building on a slave with the warnings plugin (v1.15) enabled the
      build fails with a FileNotFoundException. The filename reported in the exception
      is correct and that file is present for the entire build.

      ...
      BUILD SUCCESSFUL
      Total time: 32 minutes 28 seconds
      Recording test results
      [FINDBUGS] Collecting findbugs analysis files...
      [FINDBUGS] A total of 0 annotations have been found for priority HIGH
      [FINDBUGS] A total of 67 annotations have been found for priority NORMAL
      [FINDBUGS] A total of 0 annotations have been found for priority LOW
      [WARNINGS] Parsing warnings in log file...
      [WARNINGS] A total of 0 annotations have been found for priority HIGH
      [WARNINGS] A total of 263 annotations have been found for priority NORMAL
      [WARNINGS] A total of 0 annotations have been found for priority LOW
      FATAL: remote file operation failed
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:311)
      at hudson.FilePath.copyTo(FilePath.java:736)
      at
      hudson.plugins.warnings.util.HealthAwarePublisher.replaceRemoteReferencesWithLoc
      alFiles(HealthAwarePublisher.java:210)
      at
      hudson.plugins.warnings.util.HealthAwarePublisher.perform(HealthAwarePublisher.j
      ava:172)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java
      :309)
      at
      hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java
      :297)
      at hudson.model.Build$RunnerImpl.post2(Build.java:118)
      at
      hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:282)
      at hudson.model.Run.run(Run.java:802)
      at hudson.model.Build.run(Build.java:85)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)
      Caused by: java.io.FileNotFoundException: [exec] d:\hudson\workspace\commit-
      trigger\product\data\src\cpp\extractor\Extractor.h (The filename, directory
      name, or volume label syntax is incorrect)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(Unknown Source)
      at hudson.FilePath$21.invoke(FilePath.java:738)
      at hudson.FilePath$21.invoke(FilePath.java:736)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1122)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:206)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
      Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          I finally managed it to set up a master slave configuration on my machine so
          that I could test on my own. I activated the copying of remote files to the
          master again. It works fine on my machine. Could you please check if your
          warnings are linked to the source content now? I'm catching
          FileNotFoundExceptions now, if there is a problem then the exception is shown in
          the linked source file.

          The next release will be available soon.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : drulli
          Path:
          trunk/hudson/plugins/checkstyle/src/main/java/hudson/plugins/checkstyle/util/HealthAwarePublisher.java
          trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/util/HealthAwarePublisher.java
          trunk/hudson/plugins/pmd/src/main/java/hudson/plugins/pmd/util/HealthAwarePublisher.java
          trunk/hudson/plugins/tasks/src/main/java/hudson/plugins/tasks/util/HealthAwarePublisher.java
          trunk/hudson/plugins/warnings/src/main/java/hudson/plugins/warnings/util/HealthAwarePublisher.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=12150
          Log:
          [FIXED JENKINS-2371] Reverted changes that copy files from slave to master.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              lukenuix lukenuix
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: