Details

    • Type: New Feature
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:
      Show 5 results

      Description

      Using Maven 2.1.0.M1-RC17
      http://people.apache.org/~jdcasey/stage/current-maven-RC/ with Hudson fails due
      to not properly initialized instance of LifecycleExecutorInterceptor (for
      details please check the Maven user list
      http://www.nabble.com/Re%3A--PLEASE-TEST--Maven-2.0.10-RC11-p19207144.html ).

      The corresponding warning looks like these ones:

      [WARNING]

                            • WARNING ************

      This Maven runtime contains a LifecycleExecutor component with an incomplete
      configuration.

      LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
      Missing component requirement: org.apache.maven.project.MavenProjectBuilder

      NOTE: This seems to be a third-party Maven derivative you are using. If so,
      please notify the developers for this derivative project of the problem. The
      Apache Maven team is not responsible for maintaining the integrity of
      third-party component overrides.

      [WARNING]

                            • WARNING ************

      This Maven runtime contains a LifecycleExecutor component with an incomplete
      configuration.

      LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
      Missing component requirement:
      org.apache.maven.project.interpolation.ModelInterpolator

      NOTE: This seems to be a third-party Maven derivative you are using. If so,
      please notify the developers for this derivative project of the problem. The
      Apache Maven team is not responsible for maintaining the integrity of
      third-party component overrides.

      Cheers,
      Torsten

        Attachments

          Issue Links

            Activity

            mbeerman mbeerman added a comment -

            FYI, Maven 2.1.0-M1 was released last night, so I suspect this issue is going
            to become more important very soon...

            jramsdale jramsdale added a comment -

            Is this issue simply an annoyance or a real problem? What are the consequences
            of the mis-configuration?

            Reason for asking, my m2 builds are failing under 2.1M1. I've reported issue
            2662 (https://hudson.dev.java.net/issues/show_bug.cgi?id=2662) with my failure
            message. I'm wondering if the issues are related...

            retronym retronym added a comment -

            If you run the site goal, the build fails. If you run just to install, the build
            succeeds.

            jramsdale jramsdale added a comment -

            Issue 2662 is unrelated--it was a bogus pom in the central repository.

            I have indeed been experiencing the problem with 'mvn site' for over a month.

            lukewpatterson lukewpatterson added a comment -

            I have problems running to site. I see problems similar to
            http://jira.codehaus.org/browse/MNG-3704. (that bug is marked closed, but I
            still see the issue.)

            joshsmith joshsmith added a comment -

            Maven 2.1.0 has been released. This issue may start appearing for more users now
            that there is an official release.

            http://jira.codehaus.org/secure/ReleaseNote.jspa?
            version=14587&styleName=Html&projectId=10500&Create=Create

            candrews candrews added a comment -

            CC'ing myself

            frohman frohman added a comment -

            CC'ing myself

            mdonohue mdonohue added a comment -
                • Issue 3366 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment -

            Issue 3366 had an easier to understand summary.

            thomasd thomasd added a comment -

            cc'ed

            jonathanjohnson jonathanjohnson added a comment -

            My nightly builds have been broken since going to 2.1. I posed an issue here,
            perhaps in the wrong database, but at least multiple people are reporting this.

            http://jira.codehaus.org/browse/MNG-4137

            mdonohue mdonohue added a comment -
                • Issue 3468 has been marked as a duplicate of this issue. ***
            javanet_ac javanet_ac added a comment -

            This needs to be fixed asap. Tested with Hudson ver. 1.301
            Our Hudson-builds are broken; the message is (as already reported):

            java.lang.NullPointerException
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.calculateConcreteConfiguration(DefaultLifecycleExecutor.java:747)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:578)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:540)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.forkProjectLifecycle(DefaultLifecycleExecutor.java:1168)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.forkLifecycle(DefaultLifecycleExecutor.java:1009)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:627)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeStandaloneGoal(DefaultLifecycleExecutor.java:553)
            at
            org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:523)
            ...
            ...

            javanet_ac javanet_ac added a comment -

            This P1-issue has by far the most votes of ALL Hudson issues.

            So hopefully a solution will be found in due time. For us this is a k.o.
            criteria; and for the others it will (probably) become a crucial issue as soon
            as they start to build with Maven 2.1.0

            malachid malachid added a comment -

            I am temporarily getting around it by doing the site-deploy portion as a batch task

            mdonohue mdonohue added a comment -

            I don't use maven myself, but from what I understand of this issue, the fix
            isn't all that complicated - it's implementing some missing methods. We just
            need someone to step up and commit a few hours to do this. Given how much time
            Hudson has saved everyone, I don't expect this is that much to ask.

            malachid malachid added a comment -

            Looking at
            http://svn.apache.org/viewvc/maven/components/branches/maven-2.1.x/maven-core/src/main/java/org/apache/maven/lifecycle/DefaultLifecycleExecutor.java?view=annotate
            it does not appear that the DefaultLifecycleExecutor ever sets the
            mavenProjectBuilder (that it is complaining about) unless it gives the error...

            I downloaded the Hudson code and was trying to build it to test against, but it
            is failing to build due to
            org.apache.maven.plugins:maven-enforcer-plugin:pom:13-SNAPSHOT (even though the
            latest version of the plugin from the referenced repository is at
            <latest>1.0-beta-1</latest>).

            I'll try to take a look at this if I can get Hudson to build.

            jonathanjohnson jonathanjohnson added a comment -

            Please be aware that in http://jira.codehaus.org/browse/MNG-4137 John Casey
            reported he may be addressing the issue in Maven.

            malachid malachid added a comment -

            He has already added the warnOfIncompleteComponentConfiguration bit in Maven for
            MavenProjectBuilder.ROLE, ModelInterpolator.ROLE and ConfigurationInterpolator.ROLE.

            That's what generates the warnings this bug is reporting.

            We still need to modify our LifecycleExecutor to get rid of these warnings.

            malachid malachid added a comment -

            Just an FYI for anyone else trying to help with this. In order to get Hudson to
            build, I had to disable the Apache snapshot repositories in Nexus and then do
            an 'mvn -U' to fix the altered metadata.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/tasks/Maven.java
            trunk/hudson/main/maven-agent/src/main/java/hudson/maven/agent/Main.java
            trunk/hudson/main/maven-agent/src/main/resources/hudson/maven/agent/classworlds-2.0.6.conf
            trunk/hudson/main/maven-agent/src/main/resources/hudson/maven/agent/classworlds.conf
            trunk/hudson/main/maven-plugin/pom.xml
            trunk/hudson/main/maven-plugin/src/main/java/hudson/maven/MavenComputerListener.java
            trunk/hudson/main/maven-plugin/src/main/java/hudson/maven/MavenProcessFactory.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=18036
            Log:
            [FIXED JENKINS-2373] Modified to work with Maven 2.1. Sorry for a long delay, folks. This change will be in 1.305.

            jonathanjohnson jonathanjohnson added a comment -

            After upgrading to Hudson ver. 1.306 and sticking with Maven 2.1 my nightly
            site report is building again without the error.

            cdehning cdehning added a comment -

            Using Maven 2.2.0 and Hudson 1.314 now and the fix seems to be gone. In addition
            I'm getting one extra warning now:

            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete
            configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.project.MavenProjectBuilder

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache
            Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete
            configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement:
            org.apache.maven.project.interpolation.ModelInterpolator

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache
            Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete
            configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.ConfigurationInterpolator

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache
            Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/core/src/main/java/hudson/tasks/Maven.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=19573
            Log:
            [FIXED JENKINS-2373] in 1.316.
            Fixed "incomplete LifecycleExecutor" warning with Maven 2.2
            (<a href="https://hudson.dev.java.net/issues/show_bug.cgi?id=2373">issue 2373</a>)

            mdonohue mdonohue added a comment -

            Also see issue 4023 for issues with Maven 2.2

            kohsuke Kohsuke Kawaguchi added a comment -
                • Issue 4023 has been marked as a duplicate of this issue. ***
            steffeng steffeng added a comment -

            Maven 2.1 is not yet fully supported, as the interceptor is still compiled with
            an old interface version [1] that has changed with 2.1.

            I'm observing the second problem described in issue 3449 with hudson 1.323 and
            maven 2.2.1:
            java.lang.NoSuchMethodError:
            org.apache.maven.plugin.PluginManagerException.<init>(Ljava/lang/String;Ljava/lang/Exception;)V
            at
            hudson.maven.agent.PluginManagerInterceptor.executeMojo(PluginManagerInterceptor.java:195)

            This code is run exceptional, but the exception to be chained in the executeMojo
            method is thrown by surefire (and is not too exotic) and swallowed completely.

            I looked at the packaged implementation of the PluginManagerInterceptor.
            This is still compiled with the old interface (decompiled code):

            /* 195*/ throw new PluginManagerException(e.getMessage(), e);
            [...]
            /* 195*/ // 45 87:invokespecial #21 <Method void
            PluginManagerException(String, Exception)>

            I could think of these options:

            • use reflection to instantiate the exception (strange but simple and does the
              trick for a while)
            • extract and overwrite the exception handling method (both jars must be modified)
            • compile the interceptor in two versions (no idea how to do that easily)
            • do something that is even cooler but fixes the problem

            [1]
            http://svn.apache.org/viewvc/maven/maven-2/branches/maven-2.2.x/maven-core/src/main/java/org/apache/maven/plugin/PluginManagerException.java?r1=685450&r2=747855&diff_format=h

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : kohsuke
            Path:
            trunk/hudson/main/maven-interceptor/src/main/java/hudson/maven/agent/PluginManagerInterceptor.java
            trunk/www/changelog.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=22857
            Log:
            [FIXED JENKINS-2373] Fixed <tt>NoSuchMethodError</tt> error during error recovery with Maven 2.1. Will be in 1.330.

            kohsuke Kohsuke Kawaguchi added a comment -

            The underlying binary incompatible change is filed as http://jira.codehaus.org/browse/MNG-4550

            dsmiley dsmiley added a comment -

            This is supposedly fixed I see but I'm still getting the triple-warnings taking up a half-page of my screen, starting each build. I'm using Hudson v1.372 and Maven 2.2.1

            rdomingo rdomingo added a comment -

            In build 1.378 my mvn 2.1 projects aren't build correctly, phase 'prepare-package' isn't executed and I get:

            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.project.MavenProjectBuilder

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            Should 'prepare-package' already work in hudson 1.378 ? Is there any workaround for this ?

            kiechu kiechu added a comment -

            I received the same warning (underneath) with Hudson 1.381 and Maven 2.2.1 on Ubuntu 10.04.1 LTS with both Sun Java6 JDK and Open Java 6 JDK.

            [bo-main-portlet] $ /usr/lib/jvm/java-6-sun/bin/java -cp /opt/hudson/work/plugins/maven-plugin/WEB-INF/lib/maven-agent-1.351.jar:/usr/share/maven2/boot/classworlds.jar hudson.maven.agent.Main /usr/share/maven2/ /opt/hudson/war/WEB-INF/lib/remoting-1.351.jar /opt/hudson/work/plugins/maven-plugin/WEB-INF/lib/maven-interceptor-1.351.jar 37014
            <===[HUDSON REMOTING CAPACITY]===>���channel started
            Executing Maven: -B -f /opt/hudson/work/jobs/bo-main-portlet-new/workspace/web/portlets/bo-main-portlet/pom.xml integration-test
            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.project.MavenProjectBuilder

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.project.interpolation.ModelInterpolator

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.ConfigurationInterpolator

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache Maven team is not
            responsible for maintaining the integrity of third-party component overrides.

            lynggaard lynggaard added a comment -

            I am wondering about this line you have pasted:

            "[bo-main-portlet] $ /usr/lib/jvm/java-6-sun/bin/java -cp /opt/hudson/work/plugins/maven-plugin/WEB-INF/lib/maven-agent-1.351.jar:/usr/share/maven2/boot/classworlds.jar hudson.maven.agent.Main /usr/share/maven2/ /opt/hudson/war/WEB-INF/lib/remoting-1.351.jar /opt/hudson/work/plugins/maven-plugin/WEB-INF/lib/maven-interceptor-1.351.jar 37014"

            My concern is that the maven-interceptor and remoting jar files have a much older version number than 1.381. I checked my hudson_home and in there the version numbers match my hudson version 1.382.

            How have you installed hudson and maven, and in which container do you run hudson ?

            kutzi kutzi added a comment -

            No further info provided by reopener -> marking as Fixed again

            linuxmaniac Victor Seva added a comment -

            system: Debian squeeze
            jenkins: 1.439 (deb package)
            tomcat: 6.0.28-9+squeeze1
            maven: 2.2.1-5
            openjdk-6-jdk: 6b18-1.8.9-0.1~squeeze1

            output:
            ---------------------------------------------------------------------------------------------------------------
            Parsing POMs
            [workspace] $ java -Xmx512m -XX:MaxPermSize=256m -Djava.util.prefs.systemRoot=~/.java -cp /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven-agent-1.2.jar:/usr/share/maven2/boot/classworlds.jar hudson.maven.agent.Main /usr/share/maven2 /var/lib/tomcat6/webapps/jenkins/WEB-INF/lib/remoting-2.11.jar /var/lib/jenkins/plugins/maven-plugin/WEB-INF/lib/maven-interceptor-1.2.jar 37455
            <===[JENKINS REMOTING CAPACITY]===>channel started
            Executing Maven: -B -f /var/lib/jenkins/jobs/jboss_cervantesvirtual-gestor/workspace/pom.xml clean gwt:compile package -Dmaven.test.skip=true
            [WARNING]

                                  • WARNING ************

            This Maven runtime contains a LifecycleExecutor component with an incomplete configuration.

            LifecycleExecutor class: org.apache.maven.lifecycle.LifecycleExecutorInterceptor
            Missing component requirement: org.apache.maven.project.MavenProjectBuilder

            NOTE: This seems to be a third-party Maven derivative you are using. If so, please
            notify the developers for this derivative project of the problem. The Apache Maven team is not
            responsible for maintaining the integrity of third-party component overrides.
            ---------------------------------------------------------------------------------------------------------------

            Do you need more info?


              People

              • Assignee:
                Unassigned
                Reporter:
                tjuerge tjuerge
              • Votes:
                2 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: