Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23924

New div layout breaks Radiator view

    Details

    • Similar Issues:

      Description

      After upgrading Jenkins the Radiator view no longer works.
      The only thing displayed on the page is:

      • Pale Grey Jenkins Header bar.
      • Small black bar with question mark icon at right hand side.

      After a quick look at it:
      Radiator view has a div called "dashboard" with the following style: height: 100%; width: 100%;

      Tweaking this to height:800px for example will then show the content, although not full screen.

        Attachments

          Issue Links

            Activity

            gcummings Geoff Cummings created issue -
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Component/s core [ 15593 ]
            baldzern4 Joerg Baldzer added a comment -

            Same issue here. We patched the main.jelly file to get it working:
            Location:
            WEB-INF/classes/hudson/model/RadiatorView/main.jelly

            From:

            <div class="dashboard"
                                            style="${dashStyle} overflow: hidden; left:
                                            0px; top: 0px; position: absolute; height: 100%; width: 100%; z-index: 65535">
            

            To:

            <div class="dashboard"
                                            style="${dashStyle} overflow: hidden; left:
                                            0px; top: 0px; position: absolute; height: 95vh; width: 100vw; z-index: 65535">
            

            Not perfect, but it works as a quick fix.
            Regarding vh/vw: Modern browser will understand the new viewport values vh and vw.
            see: http://dev.w3.org/csswg/css-values/#viewport-relative-lengths

            lor Lorenzo Orsatti added a comment -

            It works also with

            <div class="dashboard"
                                            style="${dashStyle} overflow: hidden; left:
                                            0px; top: 0px; position: fixed; height: 100%; width: 100%; z-index: 65535">
            
            batmat Baptiste Mathus made changes -
            Assignee howama [ howama ] Baptiste Mathus [ batmat ]
            batmat Baptiste Mathus made changes -
            Priority Major [ 3 ] Blocker [ 1 ]
            batmat Baptiste Mathus made changes -
            batmat Baptiste Mathus made changes -
            Link This issue is duplicated by JENKINS-24104 [ JENKINS-24104 ]
            batmat Baptiste Mathus added a comment - - edited

            I'm gonna work in this one ASAP. But a bit time lacking just now, so if anyone cares about carving a pull request on the current master HEAD, that would definitely help to fix it quicker. Thanks

            batmat Baptiste Mathus made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Baptiste Mathus
            Path:
            src/main/resources/hudson/model/RadiatorView/main.jelly
            http://jenkins-ci.org/commit/radiatorview-plugin/2963821de2c7dd34840cadd15497088242e143c1
            Log:
            JENKINS-23924: fix the broken UI.

            batmat Baptiste Mathus added a comment -

            Released in 1.19, should hit update center in a few hours.

            batmat Baptiste Mathus made changes -
            Status In Progress [ 3 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            ericduell Eric Düll added a comment - - edited

            It almost works. I have upgraded to the latest Jenkins (jenkins-1.582.war) and to the latest Radiator View Plugin (1.19). The result is as shown in the attached screenshot (JENKINS-23924_brokenUI.gif). I have used FF 24.6.0 and Chrome 37.0.2062.120 m. Can anyone please review that and hopefully reopen the issue.

            ericduell Eric Düll made changes -
            Attachment JENKINS-23924_brokenUI.gif [ 27700 ]
            batmat Baptiste Mathus added a comment -

            Thanks for the feedback. Weird. I checked on Jenkins 1.580 with many browsers, could you please check if it works better for you with 1.580 so that we can narrow the scope of that issue?
            Could you please also test with a recent version of Firefox to see if the issue is still present with recent ones?

            And finally if you can propose a patch like some above, that might also help fix the issue correctly.

            Thanks

            marcuslinke Marcus Linke added a comment -

            The issue should be reopened at least. Thanks!

            batmat Baptiste Mathus added a comment - - edited

            @Marcus, please see my previous comment. If you can give all the details you can, that'd help.
            I just rechecked with dozens of projects here, and it works fine for me.

            I'm not gonna work on this if I can't reproduce it.

            As I already said

            • Does it also work for you with Jenkins 1.580?
            • Which browser/env (precise versions)
            • Your jenkins version where it doesn't work.
            • your radiator view plugin configuration: display stable jobs? Show as project? Which plugin version? And so on.

            Thanks

            marcuslinke Marcus Linke added a comment -

            I'm using latest Jenkins 1.582 and Radiator 1.19 here and tested with Firefox 32.0.3 and Chrome 37.0.2062.124 under MacOS 10.8.5. The only option that is enabled in the view is 'Use dark background'. The attached UI screenshot JENKINS_23924.jpg is taken with Firefox.

            ericduell Eric Düll added a comment - - edited

            @Baptiste: Sorry that I did not respond earlier.

            Does it also work for you with Jenkins 1.580?
            Can you please provide a download link? The homepage only points to http://mirrors.jenkins-ci.org/war/latest/jenkins.war (what is currently 1.582)

            Could you please also test with a recent version of Firefox to see if the issue is still present with recent ones?
            Due to company regulations we are sticked to the Firefox 24.x branch. I am using the version 24.6.0. from 10-Jun-2014 09:37. I will try another FF one (standalone) later. Anyhow: I tried it with Google chrome: Same result.

            Which browser/env (precise versions)
            FF 24.6.0 and Chrome 37.0.2062.120 m

            Your jenkins version where it doesn't work.
            1.582

            your radiator view plugin configuration: display stable jobs? Show as project? Which plugin version? And so on.

            • Version: 1.19
            • Confguration
              • Filter build queue: no
              • Filter build executors: no
              • Caption text: ""
              • Caption size: 36
              • Recurse in subfolders: yes
              • Use a regular expression to include jobs into the view: ".*"
              • Show stable builds?: no
              • Show stable detail?: no
              • Use Dark Background?: yes
              • Show as Projects?: no
              • Show build stability?: no
            marcuslinke Marcus Linke added a comment -

            Screenshot

            marcuslinke Marcus Linke made changes -
            Attachment JENKINS-23924.jpg [ 27720 ]
            ericduell Eric Düll added a comment - - edited

            Have a look at the following css:

            style.css (line 121)
            body, table, form, input, td, th, p, textarea, select {
             -->    remove "background-color" and it looks better.
            }
            ircbot Jenkins IRC Bot made changes -
            Component/s radiatorviewplugin [ 16046 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 156790 ] JNJira + In-Review [ 195507 ]

              People

              • Assignee:
                batmat Baptiste Mathus
                Reporter:
                gcummings Geoff Cummings
              • Votes:
                7 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: