Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24216

executeOn is created even for non-matrix jobs when updating config with REST API

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: postbuildscript-plugin
    • Labels:
      None
    • Environment:
      Jenkins core 1.560, PostBuildScript plugin 0.16.
    • Similar Issues:

      Description

      When the config is updated through the REST API an entry appears in the XML:

      <executeOn>BOTH</executeOn>

      If the config is edited through the web i/f, it is removed again.

      This occurs for non-matrix jobs, that shouldn't even have this parameter.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Gregory Boissinot Any particular reason you assigned this to core? Seems to be a Postbuildscript plugin issue.

          gbois Gregory Boissinot added a comment -

          Sorry an error. I belived it was not related to postbuildscript plugin.

          gbois Gregory Boissinot added a comment -

          Could you give me a reproductible sample?

          magjac Magnus Jacobsson added a comment -

          I think Daniel already has pointed out where the problem is. Follow his link. You just need to qualify that line with that the job being a matrix job. You can see the problem with any job. If you need a script to upload through the REST API, I may be able to create one for you. Let me know if you need it.

          dheid Daniel Heid added a comment -

          Fixed by https://github.com/jenkinsci/postbuildscript-plugin/commit/6c7f614774ab467187644b4a181424f272c72630

          There is an own extension point for Matrix PostBuildScript steps. This way there won't be a executeOn property on simple PostBuildScripts any longer. Closing the ticket.


            People

            • Assignee:
              dheid Daniel Heid
              Reporter:
              magjac Magnus Jacobsson
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: