Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: core
    • Labels:
    • Environment:
      Windows 7 64-bit
      Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
      Jenkins ver. 1.565.1
    • Similar Issues:

      Description

      Facing permanent hangs on /restart (or via update center).

      "Please wait while Jenkins is restarting..."

      The error log shows only these two rows at the time of restart and no further logging once it hangs.

      Jul 25, 2014 1:02:50 PM jenkins.model.Jenkins$24 run
      INFO: Restart in 10 seconds
      Jul 25, 2014 1:03:00 PM jenkins.model.Jenkins$24 run
      SEVERE: Restarting VM as requested by anonymous

      Reported by a few users at the following link, one user posted a thread dump from the java process after hanging occurs.
      https://groups.google.com/forum/#!topic/jenkinsci-users/Ay0uNFlVrXY

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Does it log something in jenkins.err.log? JENKINS-22685 comes to mind, as several comments indicate it's not actually fixed.

            reignmang Reign ManG added a comment -

            Nothing else gets logged in jenkins.err.log, "SEVERE: Restarting VM as requested by anonymous" is the very last thing.

            reignmang Reign ManG added a comment -

            I upgraded to LTS Release 1.565.2 and it appears that the problem has been resolved. Marking this issue as fixed.

            nkjensen Niels Kristian Jensen added a comment -

            I see this issue at every single restart, safeRestart or not. It seems to be related to the connected slaves:

            aug. 10, 2017 1:00:08 PM jenkins.model.Jenkins$26 run
            INFO: Restart in 10 seconds
            aug. 10, 2017 1:00:18 PM jenkins.model.Jenkins$26 run
            SEVERE: Restarting VM as requested by nkj
            aug. 10, 2017 1:00:18 PM jenkins.model.Jenkins cleanUp
            INFO: Stopping Jenkins
            aug. 10, 2017 1:00:18 PM jenkins.model.Jenkins$21 onAttained
            INFO: Started termination
            aug. 10, 2017 1:00:18 PM jenkins.model.Jenkins$21 onAttained
            INFO: Completed termination
            aug. 10, 2017 1:00:18 PM jenkins.model.Jenkins _cleanUpDisconnectComputers
            INFO: Starting node disconnection
            aug. 10, 2017 1:00:18 PM jenkins.slaves.DefaultJnlpSlaveReceiver channelClosed
            WARNING: safe-restart thread for EAC3 Win10 (dtdkcphpw200044) terminated
            java.nio.channels.ClosedChannelException

            environment: Windows 2008 server, slaves are Jnlp connected windows 10 and SSH connected Linux. Jenkins version 2.73.

            Please NOTE: I run the Jenkins service as an Active Directory user, not a local system account.

            The result is that Jenkins stops, but never restarts:
            INFO: Waiting for node disconnection completion
            aug. 10, 2017 1:00:20 PM jenkins.model.Jenkins cleanUp
            INFO: Jenkins stopped
            If I look at the service state using "Services", Jenkins appear to be running. A "Restart the service" brings it back up.

            danielbeck Daniel Beck added a comment -

            The result is that Jenkins stops, but never restarts:

            This indicates your issue is different from the one reported here. Please file a new bug.


              People

              • Assignee:
                Unassigned
                Reporter:
                reignmang Reign ManG
              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: