Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24295

Gerrit Cancel doesn't work for Matrix jobs

    Details

    • Similar Issues:

      Description

      The "Build Current Patches Only" feature works great for all normal jobs. But matrix jobs are not canceled when they are still running and a new patch is uploaded.

        Attachments

          Activity

          rschulz Roland Schulz created issue -
          rschulz Roland Schulz made changes -
          Field Original Value New Value
          Summary Gerrit Cancel doesn't work Matrix job Gerrit Cancel doesn't work for Matrix jobs
          rschulz Roland Schulz added a comment -

          It seems to work correctly for matrix jobs as long as all the sub-jobs have been started at the time the patch is uploaded. But if some sub-jobs are still waiting on an executor to become available, than those waiting jobs are not deleted from the queue.

          rin_ne rin_ne made changes -
          Assignee rsandell [ rsandell ] rin_ne [ rin_ne ]
          rin_ne rin_ne made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          rin_ne rin_ne made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          rin_ne rin_ne added a comment -

          I can reproduce then find root cause. New PR is created.

          rin_ne rin_ne made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: rinrinne
          Path:
          src/main/java/com/sonyericsson/hudson/plugins/gerrit/trigger/hudsontrigger/GerritTrigger.java
          http://jenkins-ci.org/commit/gerrit-trigger-plugin/8b0e9be7c5be6c70c53aeb25c8a1a258ac3d54da
          Log:
          Add one-off executor to search list for cancel job

          By "Build Current Pathcset Only" feature, running and queued jobs with
          the same change are canceled. These are found in queue items and
          executors.

          But MatrixJob uses one-off executor. It is not included in executors. So
          it cannot be canceled.

          This patch adds one-off executors to executor's list.

          Fix for JENKINS-24295

          Task-Url: https://issues.jenkins-ci.org/browse/JENKINS-24295

          rin_ne rin_ne made changes -
          Assignee rin_ne [ rin_ne ] rsandell [ rsandell ]
          ircbot Jenkins IRC Bot made changes -
          Component/s matrix-project [ 18765 ]
          Component/s matrix [ 15501 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 157213 ] JNJira + In-Review [ 195638 ]

            People

            • Assignee:
              rsandell rsandell
              Reporter:
              rschulz Roland Schulz
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: