Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24418

Getting NullPointer exception while executing post build steps (after successful build)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: postbuild-task-plugin
    • Labels:
      None
    • Environment:
      I running Jenkins 1.503v on tomcat server. The SCM tool used is dimensions and build is performed using Maven build XML. The resulting bundles are deployed in Archiva Maven repository post successful build completion.
    • Similar Issues:

      Description

      I have configured a post build action to deploy the bundles in Archiva repository. But I sometimes get the below error intermittently while executing the post build action step. This does not happen always but at sometimes.

      ERROR: Processing failed due to a bug in the code. Please report this to jenkinsci-users@googlegroups.com
      java.lang.NullPointerException
      at hudson.maven.MavenModuleSetBuild$1.isDescendantOf(MavenModuleSetBuild.java:246)
      at hudson.maven.MavenModuleSetBuild$1.<init>(MavenModuleSetBuild.java:215)
      at hudson.maven.MavenModuleSetBuild.getChangeSetFor(MavenModuleSetBuild.java:208)
      at hudson.maven.FilteredChangeLogSet.<init>(FilteredChangeLogSet.java:51)
      at hudson.maven.MavenBuild.getChangeSet(MavenBuild.java:183)
      at hudson.tasks.MailSender.appendBuildUrl(MailSender.java:216)
      at hudson.tasks.MailSender.createBackToNormalMail(MailSender.java:181)
      at hudson.tasks.MailSender.getMail(MailSender.java:168)
      at hudson.tasks.MailSender.execute(MailSender.java:100)
      at hudson.maven.reporters.MavenMailer.end(MavenMailer.java:55)
      at hudson.maven.AbstractMavenBuilder.end(AbstractMavenBuilder.java:103)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:758)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:593)
      at hudson.model.Run.execute(Run.java:1567)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:237)
      project=hudson.maven.MavenModuleSet@77dbb506[DGW_Release_6_Build]
      project.getModules()=[hudson.maven.MavenModule@58759e1d[DGW_Release_6_Build/com.centurylink.dgw:dgwmanualrepairschema][DGW_Release_6_Build/com.centurylink.dgw:dgwmanualrepairschema][relativePath:DGWManualRepairSchema], hudson.maven.MavenModule@38e0028d[DGW_Release_6_Build/com.centurylink.dgw:dgwprocessor][DGW_Release_6_Build/com.centurylink.dgw:dgwprocessor][relativePath:DGWProcessor], hudson.maven.MavenModule@7e6a41ea[DGW_Release_6_Build/com.centurylink.dgw:dgwschema][DGW_Release_6_Build/com.centurylink.dgw:dgwschema][relativePath:DGWSchema], hudson.maven.MavenModule@2b029273[DGW_Release_6_Build/com.centurylink.dgw:dgwstatusreporterschema][DGW_Release_6_Build/com.centurylink.dgw:dgwstatusreporterschema][relativePath:DGWStatusReporterSchema], hudson.maven.MavenModule@3c3173ad[DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][relativePath:DGWWorkflow]]
      project.getRootModule()=hudson.maven.MavenModule@3c3173ad[DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][DGW_Release_6_Build/com.centurylink.dgw:dgwworkflow][relativePath:DGWWorkflow]
      FATAL: null

        Attachments

          Activity

          Hide
          seanhead sean head added a comment -

          I'm seeing something similar to this.

          Right before the post build steps run I get
          "FATAL: null
          java.lang.NullPointerException"

          In the console log for the job run, nothing related in the jenkins log.

          Show
          seanhead sean head added a comment - I'm seeing something similar to this. Right before the post build steps run I get "FATAL: null java.lang.NullPointerException" In the console log for the job run, nothing related in the jenkins log.
          Hide
          danielbeck Daniel Beck added a comment -

          sean head: Make sure you're not running 1.576, it's known to throw NPEs all over.

          Show
          danielbeck Daniel Beck added a comment - sean head : Make sure you're not running 1.576, it's known to throw NPEs all over.
          Hide
          danielbeck Daniel Beck added a comment -

          Issue needs to be reproduced in a recent Jenkins version. Use 1.565.x or 1.570+ with recent Maven project plugin.

          Show
          danielbeck Daniel Beck added a comment - Issue needs to be reproduced in a recent Jenkins version. Use 1.565.x or 1.570+ with recent Maven project plugin.
          Hide
          seanhead sean head added a comment -

          Was running 1.577 and having sporadic issues. Reverting to 1.565 seems to have made them stop. I skipped 1.576 so I don't have any data for that release.

          A little more info about my setup: Master running on a dedicated ubuntu vm. 3 windows slaves (JNLP, 2x win7 64 bit, 1x win 8.1 64bit), 2x ubuntu slaves connected via swarm plugin, 6x osx slaves connected via swarm plugin (10.9.4, and 10.9.5). Heavy users of the matrix build system.

          Show
          seanhead sean head added a comment - Was running 1.577 and having sporadic issues. Reverting to 1.565 seems to have made them stop. I skipped 1.576 so I don't have any data for that release. A little more info about my setup: Master running on a dedicated ubuntu vm. 3 windows slaves (JNLP, 2x win7 64 bit, 1x win 8.1 64bit), 2x ubuntu slaves connected via swarm plugin, 6x osx slaves connected via swarm plugin (10.9.4, and 10.9.5). Heavy users of the matrix build system.
          Hide
          danielbeck Daniel Beck added a comment -
          Show
          danielbeck Daniel Beck added a comment - sean head : Please file a new issue. Provide as much information as you can, see https://wiki.jenkins-ci.org/display/JENKINS/Issue+Tracking#IssueTracking-Whattoputinthedescriptionofanissuereport%3F

            People

            • Assignee:
              Unassigned
              Reporter:
              pdhanar Premkumar Dhanarajan
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: