Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24478

Publisher hudson.plugins.cigame.GamePublisher aborted due to exception NoSuchMethodError: hudson.model.AbstractBuild.getTestResultAction()Lhudson/tasks/test/AbstractTestResultAction

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: ci-game-plugin
    • Labels:
      None
    • Environment:
      Fedora 20 64 bit
      Jenkins 1.577
      Oracle JDK 1.7.0_45
    • Similar Issues:

      Description

      the ci-game plugin is throwing the following exception:

      Recording test results
      [ci-game] evaluating rule: Build result
      [ci-game] scored: 1.0
      [ci-game] evaluating rule: Increased number of passed tests
      ERROR: Publisher hudson.plugins.cigame.GamePublisher aborted due to exception
      java.lang.NoSuchMethodError: hudson.model.AbstractBuild.getTestResultAction()Lhudson/tasks/test/AbstractTestResultAction;
      	at hudson.plugins.cigame.rules.unittesting.AbstractUnitTestsRule.getPreviousBuildWithResults(AbstractUnitTestsRule.java:49)
      	at hudson.plugins.cigame.rules.unittesting.AbstractUnitTestsRule.evaluate(AbstractUnitTestsRule.java:70)
      	at hudson.plugins.cigame.model.ScoreCard.evaluate(ScoreCard.java:102)
      	at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:45)
      	at hudson.plugins.cigame.model.ScoreCard.record(ScoreCard.java:122)
      	at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:60)
      	at hudson.plugins.cigame.GamePublisher.perform(GamePublisher.java:45)
      	at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:734)
      	at hudson.model.Build$BuildExecution.cleanUp(Build.java:192)
      	at hudson.model.Run.execute(Run.java:1786)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:89)
      	at hudson.model.Executor.run(Executor.java:240)
      

      if required I can dig into the historical logs to determine which version of Jenkins started to generate the above exception.

        Attachments

          Issue Links

            Activity

            gandalf Dell Green added a comment -

            Having the exact same problem, on my Jenkins Mac Server,

            Running Oracle JDK 1.8.0_11-b12
            Jenkins: 1.577

            gandalf Dell Green added a comment -

            it doesn't happen all the time, just randomly for the same job/s

            philipa Philip Aston added a comment -

            Good to know, thanks Daniel. How should I lobby for a release since ci-game is broken with the current version of jenkins?

            kenji Richard Bergoin added a comment - - edited

            Maybe you can install and provide feedback using this snapshot : https://jenkins.ci.cloudbees.com/job/plugins/job/ci-game-plugin/23/org.jenkins-ci.plugins$ci-game/

            EDIT : I just installed it :
            [ci-game] scored: 1.0

            philipa Philip Aston added a comment -

            Looking good.

            [ci-game] scored: 1.0

            Thanks

            avoinea Alin Voinea added a comment -

            Same issue here. Can you release the fix, please.

            dirk_olmes Dirk Olmes added a comment -

            I can confirm that the snapthos link you provided above works. Please release a fixed version.

            jsotuyod Juan Sotuyo added a comment -

            How long is it going to be before a formal release is made of that working plugin snapshot? It's been almost 3 months since the bug was first submitted...

            steven_brady Steve Brady added a comment -

            Waiting for an update also. The link above to the snapshot no longer works.
            Please advise.

            jsotuyod Juan Sotuyo added a comment -
            steven_brady Steve Brady added a comment -

            Thank you Juan Sotuyo. I also confirm this snapshot works.

            chiranth1988 Chiranth Bantwal added a comment -

            Thanks @jsotuyod. The snapshot saved my day!

            r2b2_nz Richard Bywater added a comment -

            Have asked the last person to merge a pull request if they intend to perform a release. If that doesn't happen then we should probably look at just releasing the current master anyway to try and resolve this issue.

            r2b2_nz Richard Bywater added a comment -

            Contacted 'simschla' who wasn't aware that this issue existed. Now he does he is going to look at doing a release as soon as he is able.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Simon Schlachter
            Path:
            pom.xml
            http://jenkins-ci.org/commit/ci-game-plugin/c8cceef5532af5c8ac167818a97c88cd960371cc
            Log:
            JENKINS-24478: bump version numbers of dependencies

            the version updates are necessary due to api changes in jenkins that break old implementations. in order to support the new api, the min version of jenkins core had to be bumped - and with it the plugins we use (checkstyle, findbugs et. al)

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Simon Schlachter
            Path:
            pom.xml
            src/test/java/hudson/plugins/cigame/GamePublisherTest.java
            http://jenkins-ci.org/commit/ci-game-plugin/c773f247881b4d59c67f2ef2d8e5dd49d7853774
            Log:
            JENKINS-24478: fix failing due to new jenkins-core dependencies

            Compare: https://github.com/jenkinsci/ci-game-plugin/compare/cd6c3b9dfcf4...c773f247881b

            cappuccino Simon Gamma added a comment -

            Hey Guys, I had to bump some of the version numbers on our dependencies in order to be able to fully use the changed API. Now everything looks good.

            I'll release a new version as soon as the jenkins-infra-guys are able to get the release-mechanism working again.

            See INFRA-240 for that, if you are interested.

            drphrozen Esben Rasmussen added a comment -

            Excellent work

            cappuccino Simon Gamma added a comment -

            OK, changes are included in version 1.21 - can you please verify?

            jsotuyod Juan Sotuyo added a comment -

            Working for me


              People

              • Assignee:
                cappuccino Simon Gamma
                Reporter:
                abarbieri Andrea Barbieri
              • Votes:
                21 Vote for this issue
                Watchers:
                31 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: