Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24743

Findbug and PMD are broken in Jenkins 1.565.2

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: findbugs-plugin, pmd-plugin
    • Labels:
      None
    • Environment:
      windows server 2012 R2 and windows7
    • Similar Issues:

      Description

      I have upgraded Jenkins to version 1.565.2 and after that when we are running Findbugs and PMD jobs they are failing with nullpointer exception code snippet is shown below

      [FINDBUGS] Collecting findbugs analysis files...
      ERROR: Publisher hudson.plugins.findbugs.FindBugsPublisher aborted due to exception
      java.lang.NullPointerException
      at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
      at hudson.plugins.findbugs.parser.FindBugsParser.preParse(FindBugsParser.java:229)
      at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:187)
      at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:172)
      at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:140)
      at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:300)
      at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:258)
      at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:209)
      at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:178)
      at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2474)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:328)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:63)
      at java.lang.Thread.run(Unknown Source)
      [PMD] Collecting PMD analysis files...
      ERROR: Publisher hudson.plugins.pmd.PmdPublisher aborted due to exception
      java.lang.NullPointerException
      at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
      at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
      at hudson.plugins.pmd.parser.PmdParser.parse(PmdParser.java:70)
      at hudson.plugins.analysis.core.AbstractAnnotationParser.parse(AbstractAnnotationParser.java:53)
      at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:300)
      at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:258)
      at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:209)
      at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:178)
      at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2474)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:328)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:63)
      at java.lang.Thread.run(Unknown Source)

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Which versions did you install (findbugs, pmd, analysis-core)?

          drulli Ulli Hafner added a comment -

          Which Java version? How do you start Jenkins? Seems a problem when loading the SAX parser.

          I just installed 1.565.2 with PMD and findbugs and started a job with both tools: everything went fine.

          drulli Ulli Hafner added a comment -

          BTW: Which Jenkins version was installed before your upgrade?

          bhnau_pathak bhanu pathak added a comment -

          Java version is jdk1.7.0_67 , Findbugs version is 4.57 . PMD version is 3.38, somehow it is not showing analysis core plugin as installed , but neither there is any logs of saying that plugin is not loaded.

          i have tried a restore of the data from my older sever which was running on Jenkins 1.479, i start jenkins as a windows service .

          bhnau_pathak bhanu pathak added a comment -

          actually i have checked and it seems that Jenkins does not show analysis -core plugin in its installed list of plugins , so the version of analysis core on my server is 1.59 ,do you need any logs which can be helpful

          drulli Ulli Hafner added a comment -

          The name of the plugin is "Static Analysis Utilities".

          drulli Ulli Hafner added a comment -

          Seems that the SAX parser is not found, can you please enable the logging for "org.apache.commons.digester3.Digester".

          bhnau_pathak bhanu pathak added a comment -

          can you please let me know how to enable logging for "org.apache.commons.digester3.Digester"

          drulli Ulli Hafner added a comment -

          Any news using the logger?

          skl Sylwia Kludacz added a comment -

          I'm facing the same issue and the snapshot from digester logger is following:
          Digester.getParser:
          java.lang.UnsupportedOperationException: This parser does not support specification "null" version "null"
          at javax.xml.parsers.SAXParserFactory.setSchema(Unknown Source)
          at org.apache.commons.digester3.Digester.getFactory(Digester.java:441)
          at org.apache.commons.digester3.Digester.getParser(Digester.java:652)
          at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
          at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
          at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
          at hudson.plugins.findbugs.parser.FindBugsParser.preParse(FindBugsParser.java:229)
          at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:187)
          at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:172)
          at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:140)
          at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:323)
          at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:281)
          at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:232)
          at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:201)
          at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
          at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2474)
          at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:328)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
          at java.util.concurrent.FutureTask.run(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          at hudson.remoting.Engine$1$1.run(Engine.java:63)
          at java.lang.Thread.run(Unknown Source)

          The installed versions:
          Jenkins 1.565.2
          java 1.7.0_25
          Static Analysis Utilities 1.67
          PMD plugin 3.40
          FindBugs plugin 4.58

          What could be the issue here?

          skl Sylwia Kludacz added a comment -

          Please see my comment above

          drulli Ulli Hafner added a comment - - edited

          Can you please try with more recent LTS version, e.g. 1.580.3?

          On which OS are you running Jenkins (and how?)?

          skl Sylwia Kludacz added a comment -

          Os is windows server 2012 R2 and Jenkins is running as a service. Is there anything else I can try before upgrading Jenkins?

          drulli Ulli Hafner added a comment -

          Did you try the digester logging? In your comment there is only the exception...

          skl Sylwia Kludacz added a comment -

          That is all I get from digester logging for every single job run using FindBugs plugin

          drulli Ulli Hafner added a comment -

          Did you look into the log or just your build console? You need to enable the logging for org.apache.commons.digester3.

          skl Sylwia Kludacz added a comment -

          I have enabled logging for "org.apache.commons.digester3.Digester" and the snapshot above is from the log. If I enable ""org.apache.commons.digester3" the snapshot is still the same. The snapshot from the console is little bit different:
          BUILD SUCCESSFUL
          Total time: 1 minute 2 seconds
          [FINDBUGS] Collecting findbugs analysis files...
          ERROR: Publisher hudson.plugins.findbugs.FindBugsPublisher aborted due to exception
          java.lang.NullPointerException
          at org.apache.commons.digester3.Digester.getXMLReader(Digester.java:799)
          at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
          at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
          at hudson.plugins.findbugs.parser.FindBugsParser.preParse(FindBugsParser.java:229)
          at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:187)
          at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:172)
          at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:140)
          at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:323)
          at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:281)
          at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:232)
          at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:201)
          at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
          at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2474)
          at hudson.remoting.UserRequest.perform(UserRequest.java:118)
          at hudson.remoting.UserRequest.perform(UserRequest.java:48)
          at hudson.remoting.Request$2.run(Request.java:328)
          at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
          at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
          at java.util.concurrent.FutureTask.run(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          at hudson.remoting.Engine$1$1.run(Engine.java:63)
          at java.lang.Thread.run(Unknown Source)
          An attempt to send an e-mail to empty list of recipients, ignored.
          No emails were triggered.
          Finished: FAILURE

          drulli Ulli Hafner added a comment -

          Hmm, I get a lot of messages in the following form:

            Fire end() for hudson.plugins.checkstyle.rules.TopicRule@1b58cee1
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester endElement
          
            Fire end() for SetNextRule[methodName=setDescription, paramType=null, paramTypeName=null, useExactMatch=false, fireOnBegin=false]
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester invoke
          
          [SetNextRule]{document/body/section/subsection} Call hudson.plugins.checkstyle.rules.Rule.setDescription(hudson.plugins.checkstyle.rules.Topic@20065110)
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester endElement
          
            Fire end() for SetPropertiesRule[aliases={}, ignoreMissingProperty=true]
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester endElement
          
            Fire end() for ObjectCreateRule[className=hudson.plugins.checkstyle.rules.Topic, attributeName=null]
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester end
          
          [ObjectCreateRule]{document/body/section/subsection} Pop 'hudson.plugins.checkstyle.rules.Topic'
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester.sax characters
          
          characters(
          
                )
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester.sax startElement
          
          startElement(,,subsection)
          
          Feb 04, 2015 1:54:03 PM FEIN org.apache.commons.digester3.Digester startElement
          
            Pushing body text '
                
          
          
          drulli Ulli Hafner added a comment -

          I attached a screenshot on how to create the logger...

          skl Sylwia Kludacz added a comment -

          This is exactly how the logger was created. Perhaps in my case it is not getting that far (xml parsing)?

          skl Sylwia Kludacz added a comment -

          I have also attached screenshots of the config and the logging contents

          skl Sylwia Kludacz added a comment -

          strange, I run the job again and again and after last run the digester logging shows more info:

          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax setDocumentLocator
          setDocumentLocator(org.apache.xerces.parsers.AbstractSAXParser$LocatorProxy@287e34)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startDocument
          startDocument()
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,document)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text ''
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          No rules found matching 'document'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(

          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,properties)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text '

          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document/properties'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          No rules found matching 'document/properties'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(
          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,title)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text '
          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document/properties/title'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          No rules found matching 'document/properties/title'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(Annotations)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax endElement
          endElement(,,title)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          match='document/properties/title'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          bodyText='Annotations'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          No rules found matching 'document/properties/title'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          Popping body text '
          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(
          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,author)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text '

          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document/properties/author'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          No rules found matching 'document/properties/author'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(Checkstyle Development Team)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax endElement
          endElement(,,author)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          match='document/properties/author'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          bodyText='Checkstyle Development Team'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          No rules found matching 'document/properties/author'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          Popping body text '

          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(
          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax endElement
          endElement(,,properties)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          match='document/properties'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          bodyText='

          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          No rules found matching 'document/properties'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester endElement
          Popping body text '

          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(

          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,body)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text '

          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document/body'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          No rules found matching 'document/body'.
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(
          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,section)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text '
          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document/body/section'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for ObjectCreateRule[className=hudson.plugins.checkstyle.rules.Rule, attributeName=null]
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester begin
          [ObjectCreateRule]

          {document/body/section} New 'hudson.plugins.checkstyle.rules.Rule' using default empty constructor
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for SetPropertiesRule[aliases={}, ignoreMissingProperty=true]
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester begin
          [SetPropertiesRule]{document/body/section}

          Setting property 'name' to 'name'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester begin
          [SetPropertiesRule]

          {document/body/section}

          Set 'hudson.plugins.checkstyle.rules.Rule' properties
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for SetNextRule[methodName=add, paramType=null, paramTypeName=null, useExactMatch=false, fireOnBegin=false]
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax characters
          characters(
          )
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester.sax startElement
          startElement(,,subsection)
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Pushing body text '
          '
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          New match='document/body/section/subsection'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for ObjectCreateRule[className=hudson.plugins.checkstyle.rules.Topic, attributeName=null]
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester begin
          [ObjectCreateRule]

          {document/body/section/subsection} New 'hudson.plugins.checkstyle.rules.Topic' using default empty constructor
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for SetPropertiesRule[aliases={}, ignoreMissingProperty=true]
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester begin
          [SetPropertiesRule]{document/body/section/subsection}

          Setting property 'name' to 'name'
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester begin
          [SetPropertiesRule]

          {document/body/section/subsection}

          Set 'hudson.plugins.checkstyle.rules.Topic' properties
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for SetNextRule[methodName=setDescription, paramType=null, paramTypeName=null, useExactMatch=false, fireOnBegin=false]
          Feb 04, 2015 3:39:34 PM FINE org.apache.commons.digester3.Digester startElement
          Fire begin() for hudson.plugins.checkstyle.rules.TopicRule@9d1afc
          Feb 04, 2015 3:39:34 PM SEVERE org.apache.commons.digester3.Digester startElement
          Begin event threw error
          java.lang.NoClassDefFoundError: org/w3c/dom/ElementTraversal
          at org.apache.xerces.dom.CoreDocumentImpl.createElement(Unknown Source)
          at org.apache.commons.digester3.NodeCreateRule.begin(NodeCreateRule.java:409)
          at org.apache.commons.digester3.Digester.startElement(Digester.java:1350)
          at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
          at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
          at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
          at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
          at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
          at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
          at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
          at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
          at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
          at org.apache.commons.digester3.Digester.parse(Digester.java:1642)
          at org.apache.commons.digester3.Digester.parse(Digester.java:1701)
          at hudson.plugins.checkstyle.rules.CheckStyleRules.initialize(CheckStyleRules.java:60)
          at hudson.plugins.checkstyle.CheckStylePlugin.start(CheckStylePlugin.java:20)
          at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:402)
          at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:391)
          at hudson.PluginManager$2$1$1.run(PluginManager.java:357)
          at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
          at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
          at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
          at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
          at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
          at java.lang.Thread.run(Unknown Source)

          drulli Ulli Hafner added a comment - - edited

          Ok, good to see that the logger now works.

          It would be good to see the log from the start of the job till the exception (maybe you can attach it?). The exception above is different and from checkstyle...
          java.lang.NoClassDefFoundError: org/w3c/dom/ElementTraversal
          This class is part of the xml-api that should be included in your Jenkins.

          Is your job started on Jenkins master or a slave?

          skl Sylwia Kludacz added a comment -

          the job is started on a slave node. I cleared the log and run the job again and digester log record is back to what it was previously in my comment from 04/Feb/15 1:17 PM ... Something strange is happening here...

          skl Sylwia Kludacz added a comment -

          how can I check if xml-api is included in my Jenkins?

          drulli Ulli Hafner added a comment -

          In the WEB-INF/lib folder of the findbugs plugin there should be a library: xml-apis-1.4.01.jar

          Can you please try to build the job without slave, I think the classloader in this Jenkins versions was quite new (and buggy?).

          skl Sylwia Kludacz added a comment -

          xml-apis-1.4.01.jar exists, so that's not the issue. The master has been restricted not to run any jobs and it doesn't have Perforce installed for example. I think I try to upgrade Jenkins tomorrow to 1.580.3 as suggested by you before.

          skl Sylwia Kludacz added a comment -

          I've upgraded Jenkins to latest 1.598 version but this didn't help

          drulli Ulli Hafner added a comment -

          How do you connect slave and master? Is your slave a Windows client with the same java version? Is the slave.jar up-to-date? Would it be possible to build my plug-in (run unit tests) on your slave in order to see if this is a general problem or a problem caused by Jenkins classloader?

          skl Sylwia Kludacz added a comment -

          The problem seems to be related to slave node and I was able to run the same job on different slave successfully. What exactly on the slave node is causing this issue I don't know yet as it is using the same java version as server. Will need to investigate this further

          integer Kanstantsin Shautsou added a comment -

          Jar may exist but will be not used.
          Please check that you have no plugins that do classloading before core classloading.

          drulli Ulli Hafner added a comment -

          Is this still a problem, then please reopen. I can't reproduce it.

          skl Sylwia Kludacz added a comment -

          This problem has been resolved now and it was related to xerces on Jenkins server. There were two instances of the xercesImpl.jar file on the server, one in the endorsed directory and one in the ext directory.
          It looks like Jenkins was loading the one from the endorsed directory first, the endorsed directory didn’t have the xml-apis.jar file which has dependency links from the xercesImpl.jar library.
          By deleting the lib from the endorsed folder it resolved the issue.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              bhnau_pathak bhanu pathak
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: