Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24918

Filenames of archived artifacts become garbled when they contain non-ascii characters

    Details

    • Similar Issues:

      Description

      My steps to reproduce is to
      1) Check out files from our SCM (StarTeam plugin)
      2) Verify files containing special characters are correct in the workspace (which they are)
      3) After the files have been archived using the standard Archive Artifacts Post build step, the filenames containing special chars have been garbled.

      So files are retrieved correctly from SCM but get their filename garbled upon archiving.

      In my particular case the filenames contain the characters 'æ', 'ø' and 'å'. These are the chars being garbled by the archiving step.
      I've been searching for a way of testing whether or not I could influence the setting via some sort of startup parameter to Jenkins but with no luck in finding such. Is this just because I've failed to supply the right locale setting or encoding?
      Master is a Windows 7 pc. Slave is also Windows 7.

      I tried changing the checkout and archiving task to run on the master instead of the slave. The filenames were then no longer garbled!?

      So I guess this comes down to some sort of setting different on the machines? Java version perhaps?

        Attachments

          Issue Links

            Activity

            Hide
            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-24138.

            Show
            danielbeck Daniel Beck added a comment - Duplicates JENKINS-24138 .

              People

              • Assignee:
                Unassigned
                Reporter:
                lly Lars Lykke
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: