Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: mercurial-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I am using hg version 1.0.2 and plugin 1.11. It seems that support for branches
      is completely broken.

      1. In workspace I have default branch even if I specify another in project
      settings (I check it by hg branch command)
      2. On the build start Hudson executes the command hg incoming with parameter -r
      name_of_branch. But it is wrong a branch is not a revision and I never have a
      revision with such name.

      So I did the following to setup the build on mercurial branch:

      in workspace:
      execute "hg update name_of_branch" to switch workspace to the my branch
      in Hudson settings:
      clear the branch field - so Hudson now execute hg incoming with out parameter -r
      which is more correct.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Probably related to issue #4281.

                • This issue has been marked as a duplicate of 4281 ***

              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                foal foal
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: