Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25064

Swarm toollocations don't work for all tools

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I'm sorry, I keep finding bugs in my own code...
      I noticed that the swarm client wouldn't recognize all tools, some were added as Ant installations. That's because Ant is the first item in the dropdown.
      Turns out the way I generate the toolinstallation key is not entirely correct. The keys that I have encountered that don't work are those for Ant and Maven. In my tests I always used Groovy, JDK and Ant...Ant seemed to work because it default to the first item in the listbox, being Ant..

      I have asked for some help here: https://groups.google.com/forum/#!topic/jenkinsci-dev/QwYKkMvtw9s

        Attachments

          Activity

          mr_dfuse Nico Mommaerts created issue -
          scm_issue_link SCM/JIRA link daemon made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          mindjiver Peter Jönsson made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Assignee Kohsuke Kawaguchi [ kohsuke ] Peter Jönsson [ mindjiver ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 158965 ] JNJira + In-Review [ 208120 ]

            People

            • Assignee:
              mindjiver Peter Jönsson
              Reporter:
              mr_dfuse Nico Mommaerts
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: