Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25070

Subversion fails to update externals once after external is changed.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      Jenkins ver. 1.565.1 running on Windows Server 2012.
      Slaves running on Mac, Linux, and Windows, all affected.
      Subversion Plugin 2.3
    • Similar Issues:

      Description

      SVN Check out fails at external check-out.

      This only occurs if the external has changed. In this case, the external revision was updated to a more recent version. (For us, this happens maybe once a week so).

      We run quite a number of jobs that access this same repository. Whenever the SVN External is changed, they all fail. They all fail only once and are fine the next time they run.

      The jobs themselves run on multiple machines from a pool. An individual machine does not impact the above. So, if the job-A runs on machine-X after the external change, job-A will fail. If job-B then runs on machine-X, it will fail. Then if job-A runs on machine-Y, it’s fine. Jobs need to get through this fail, machines do not.

      Note we have other jobs that use Subversion on the command line; they check out the same code but do not hit this problem.

      Our jobs are configured using a shared workspace.

      The externals all have the same access credentials. We have configured ‘Additional Credentials’ as well as the Subversion Credentials, but all are the same. Also, as this only happens after an external change, all work correctly.

      13:03:47 Fetching 'https://repo/product/trunk/tools/scripts/pyadb' at -1 into '/local/ws/BUILD_PRODUCT_TRUNK/tools/scripts/jenkins/canaries/pyadb'
      13:03:47 At revision 193923
      13:03:47 At revision 193923
      13:03:48 no change for https://repo/product/trunk/components/csf-foundation/include since the previous build
      13:03:48 no change for https://repo/product/trunk/components/common-foundation/CommonFoundation since the previous build
      13:03:48 hudson.util.IOException2: revision check failed on https://repo/product/thirdparty-allversions/internal/sipcc/imports/IMPORT_synbase_main
      13:03:48 at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:186)
      13:03:48 at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:128)
      13:03:48 at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:739)
      13:03:48 at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:900)
      13:03:48 at hudson.model.AbstractProject.checkout(AbstractProject.java:1252)
      13:03:48 at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:615)
      13:03:48 at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      13:03:48 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:524)
      13:03:48 at hudson.model.Run.execute(Run.java:1706)
      13:03:48 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      13:03:48 at hudson.model.ResourceController.execute(ResourceController.java:88)
      13:03:48 at hudson.model.Executor.run(Executor.java:232)
      13:03:48 Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: OPTIONS /product/thirdparty-allversions/internal/sipcc/imports/IMPORT_synbase_main failed
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:384)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:373)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:361)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:707)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:627)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:102)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1020)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:180)
      13:03:48 at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
      13:03:48 at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:148)
      13:03:48 at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
      13:03:48 at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
      13:03:48 at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
      13:03:48 at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:20)
      13:03:48 at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1238)
      13:03:48 at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      13:03:48 at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:967)
      13:03:48 at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:872)
      13:03:48 at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:174)
      13:03:48 ... 11 more
      13:03:48 Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: No credential to try. Authentication failed
      13:03:48 at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:37)
      13:03:48 at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:32)
      13:03:48 at org.tmatesoft.svn.core.internal.wc.DefaultSVNAuthenticationManager.getFirstAuthentication(DefaultSVNAuthenticationManager.java:185)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:694)
      13:03:48 at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:382)
      13:03:48 ... 29 more

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Externals need 'Additional Credentials' defined, see JENKINS-21785. Did you specify those?

            (Please don't post a comment there, it's too noisy already)

            jnoonan33 James Noonan added a comment -

            Yes.

            The externals are all on the same repo. The same credentials are specified in 'Additional Credentials' as for the main subversion check-out.

            Also, 99% of the time, there is no problem. It seems to be only when the external revision changes. And we are on revision 2.3.

            oleg_nenashev Oleg Nenashev added a comment -

            @James.
            Do you explicitly specify @HEAD in Subversion repo path?
            If no, see JENKINS-1241

            jnoonan33 James Noonan added a comment - - edited

            (thanks Oleg)

            We specify:
            https://repo-loc.company.com/product-all/product/trunk@$SVN_REVISION

            $SVN_REVISION is passed as a parameter to the build. We have a 'home-spun' matrix style build, so are forcing jobs to a specific revision.

            For credentials:

            • There are three 'mirrored' repos. All our externals are on our own repos. We therefore specifiy as an external each location with the appropriate credentials.

            As said, this works great, most of the time. It fails whenever an external changes. Then, each job fails once and then is fine. The jobs run on a pool of machines, so it's really each job, not machine.

            oleg_nenashev Oleg Nenashev added a comment - - edited

            I would re-open JENKINS-21785 for the issue.
            The behavior is very similar, so there could be a partial fix only in 2.3

            I tried to reproduce the case on our dev. servers, but wasn't very successful on this front

            timl timothy luksha added a comment -

            We have been experiencing a similar exception intermittently during updates executed when Jenkins does a build of our software.

            Based on James Noonan's findings, we tried changing a file in a directory that is referenced as an external. The first build's update/checkout failed with the subversion exception, and then the second build updated without any error. We have reproduced this pattern more than three times now.

            Our plugin is version 2.4.3. Is there any other information we could collect to assist with pinning this down?

            jnoonan33 James Noonan added a comment -

            Hi,

            We've updated to Subversion 2.4.4. We also updated to Jenkins ver. 1.565.3.
            However, the problem still occurs, and is quite reproducible.

            @Oleg; I'm reluctant to re-open that defect. While it's likely similar, there are clear instructions at the top of that defect, and we have followed them all.

            danielbeck Daniel Beck added a comment -

            JENKINS-21785 was resolved AFAICT. There should be nowhere left where a credential is missing (if using Additional Credentials). For now I'd treat this as a separate issue.

            sirwio sirwiö sirwiö added a comment -

            We are facing the exact problems as described in the description by the original reporter on a very similar repository setup. It is 100% reproducable.

            This is with Jenkins 1.580.2 and Subversion Plug-in 2.5

            jnoonan33 James Noonan added a comment -

            Hello Sirwio: A bit of relief that it's no longer so unique

            For us, the problem has not occurred for quite a while. We performed a number of steps to help, but there is no step we carried out that definitely stopped it.

            Two things that may have helped are that we removed the number of nodes (though it's increased again since) and removed the VM Node Plugin. The VM Node Plugin caused a lot of disconnect/connect events, so we thought that that might be a cause of stress. After removing, the problem occurred one more time.

            So, two questions:
            How do you reproduce this problem. We never had a set of steps that would make the problem happen.
            And perhaps we should compare our list of plug-ins / versions.

            sgannon200 Shane Gannon added a comment -

            It seems that nowadays the solution to https://issues.jenkins-ci.org/browse/JENKINS-21785 also resolves this problem. i.e. Set addition credentials with the correct realm name format. e.g. <https://my-server-url.com:443> ID. You can find the correct authentication realm name by using "svn --no-auth-cache --config-dir invalid info https://my-server-url.com/trunk".

            However this did not originally work for us. Not sure why it's working now. We upgraded the svn plugin to 2.5 then downgraded to 2.3. This may have had an impact. We also upgraded our version of Jenkins,

            This defect can be marked as resolved.

            danielbeck Daniel Beck added a comment -

            We upgraded the svn plugin to 2.5 then downgraded to 2.3.

            Subversion Plugin 2.5 has several known issues that may play into this.

            FWIW I think 2.4.4 (for older Jenkins) or 2.4.5 (for Jenkins 1.585+) are pretty solid and worth a try.

            egsejenkins Reece Johnston added a comment - - edited

            We are presently seeing this as well, and have seen it with Jenkins (1.569, 1.580.1, 1.617), SVN (1.6, 1.7) and for Subversion Plugin (2.4, 2.4.4, 2.5.1). Unfortunately, I need Subversion Plugin 2.4 or later due to the concurrent builds issue, so I cannot revert back to 2.3. Also, it seems to only occur on first checkout or when the external has been changed. The latter of which isn't a huge issue since the external in question is an ant build.xml that should remain rather static, but first checkouts of a project can occur quite frequently in our environment. I should also add that I have specified additional credentials for all of the jobs with a realm of "svn+ssh://host/path/to/svn", noting that this is svn+ssh protocol. For the relevant output (from Jenkins 1.580.1, SVN 1.6, and Subversion Plugin 2.5.1), see below:

            Error Output

            hudson.util.IOException2: revision check failed on svn+ssh://host/path/to/external/build.xml
            at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:196)
            at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:137)
            at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:725)
            at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:860)
            at hudson.scm.SCM.checkout(SCM.java:488)
            at hudson.model.AbstractProject.checkout(AbstractProject.java:1253)
            at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
            at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
            at hudson.model.Run.execute(Run.java:1745)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:89)
            at hudson.model.Executor.run(Executor.java:240)
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: authentication cancelled
            at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:37)
            at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:32)
            at org.tmatesoft.svn.core.internal.io.svn.SVNSSHConnector.open(SVNSSHConnector.java:149)
            at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.open(SVNConnection.java:77)
            at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.openConnection(SVNRepositoryImpl.java:1253)
            at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getLatestRevision(SVNRepositoryImpl.java:169)
            at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
            at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:184)
            at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
            at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
            at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
            at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
            at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
            at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
            at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
            at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
            at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:184)
            ... 12 more

            _markus_franke_ Markus Franke added a comment -

            Exactly the same bug hit's us as well. Once an external changes the very first built of the dependent projects fail with

            hudson.util.IOException2: revision check failed on svn+ssh://192.168.0.2/home/svn/repos/LBall/trunk/develop/DMS/src/mRD
            	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:207)
            	at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:137)
            	at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:722)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:857)
            	at hudson.scm.SCM.checkout(SCM.java:485)
            	at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
            	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
            	at hudson.model.Run.execute(Run.java:1738)
            	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            	at hudson.model.ResourceController.execute(ResourceController.java:98)
            	at hudson.model.Executor.run(Executor.java:410)
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: authentication cancelled
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:37)
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.cancel(SVNErrorManager.java:32)
            	at org.tmatesoft.svn.core.internal.io.svn.SVNSSHConnector.open(SVNSSHConnector.java:149)
            	at org.tmatesoft.svn.core.internal.io.svn.SVNConnection.open(SVNConnection.java:77)
            	at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.openConnection(SVNRepositoryImpl.java:1273)
            	at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.getLatestRevision(SVNRepositoryImpl.java:172)
            	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
            	at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:184)
            	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
            	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
            	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
            	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
            	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
            	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
            	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
            	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
            	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:193)
            	... 12 more
            
            bpetto35 Bruno Pettorelli added a comment -

            Exactly the same, when there is change on one of the many externals the project use that lead to

            hudson.util.IOException2: revision check failed on https://www.forge.orange-labs.fr/svnroot/CCA/branches/BEWV9Sandbox/BEWV9_G05R01C00/src/product/Compatibility/NetworkingServices
            	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:196)
            	at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:137)
            	at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:726)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:861)
            	at hudson.scm.SCM.checkout(SCM.java:484)
            	at hudson.model.AbstractProject.checkout(AbstractProject.java:1274)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:609)
            	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:531)
            	at hudson.model.Run.execute(Run.java:1738)
            	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            	at hudson.model.ResourceController.execute(ResourceController.java:98)
            	at hudson.model.Executor.run(Executor.java:381)
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:60)
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:759)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:371)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:359)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:710)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:627)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:102)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1032)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:175)
            	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
            	at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:184)
            	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
            	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
            	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
            	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
            	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
            	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
            	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
            	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
            	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:184)
            	... 12 more
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:689)
            	... 30 more
            
            menges_ghebre Mengesteab Ghebreyesus added a comment -

            We are also experiencing similar problem in many of our Projects during checking out from particular svn Project.. However, we get this error:
            1. If we restart Jenkins and
            2. In one of our Project from time to time in addition to restart Jenkins.

            OS : windows 7
            Jenkins Version : 1656
            Subversion Plugin 2.7

            Thank you all

            sgoetz Sebastian Götz added a comment -

            Hi guys,

            we are facing a similar problem. We have subdirectory within the same subversion repository the code resides in for common files like certificates an so on. Each time such an svn:external changes the following build fails with the message:

            hudson.util.IOException2: revision check failed on XXXX
            	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:207)
            	at hudson.scm.SubversionChangeLogBuilder.run(SubversionChangeLogBuilder.java:137)
            	at hudson.scm.SubversionSCM.calcChangeLog(SubversionSCM.java:722)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:857)
            	at hudson.scm.SCM.checkout(SCM.java:485)
            	at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
            	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
            	at hudson.model.Run.execute(Run.java:1738)
            	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            	at hudson.model.ResourceController.execute(ResourceController.java:98)
            	at hudson.model.Executor.run(Executor.java:410)
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:60)
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:793)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:398)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:386)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:863)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:699)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:118)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1049)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getLatestRevision(DAVRepository.java:189)
            	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.getRevisionNumber(SvnNgRepositoryAccess.java:118)
            	at org.tmatesoft.svn.core.internal.wc2.SvnRepositoryAccess.getLocations(SvnRepositoryAccess.java:184)
            	at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgRepositoryAccess.createRepositoryFor(SvnNgRepositoryAccess.java:45)
            	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:160)
            	at org.tmatesoft.svn.core.internal.wc2.remote.SvnRemoteLog.run(SvnRemoteLog.java:35)
            	at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
            	at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1235)
            	at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
            	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:968)
            	at org.tmatesoft.svn.core.wc.SVNLogClient.doLog(SVNLogClient.java:873)
            	at hudson.scm.SubversionChangeLogBuilder.buildModule(SubversionChangeLogBuilder.java:193)
            	... 12 more
            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:723)
            	... 30 more
            

            At the moment we are using Jenkins 1.656 with Subversion Plug-in 2.5.7 on a Windows Server 2008 machine.

            menges_ghebre Mengesteab Ghebreyesus added a comment -

            Additional Credentials fixed our problem.

            sgoetz Sebastian Götz added a comment -

            How did you suply these additional credentials? The "externals" we have are actually in the same repository (same server, same repo).

            menges_ghebre Mengesteab Ghebreyesus added a comment -

            You enter the Realm and the same Credentials again. The credential got lost, who knows what the reasen is.

            sgoetz Sebastian Götz added a comment - - edited

            Looks like this does the trick in deed. I simple removed the URI scheme filter from the domain description and saved the stuff again, although the theme was correct. Seems like now it's working.

            _markus_franke_ Markus Franke added a comment -

            What do you mean by "removed the URI scheme filter"? I still have problems to get this working.

            sgoetz Sebastian Götz added a comment - - edited

            When configuring the credentials of a domain you have the possibility to add/remove filters to specify when these credentials apply (hostname, hostname:port, URI scheme, URI path). With my specification I used the hostname and the URI scheme filter. To fix the issue I simple removed the URI scheme stuff and stored the configuration. Until now it works for me.
            EDIT:
            Unortunately just this morning the nightly build failed with the same exception then ever:
            svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.

            _markus_franke_ Markus Franke added a comment - - edited

            Hmm....sorry for that. But I did not have any URI scheme filter set and it also fails. I am still getting

            Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: authentication cancelled

            jherb Joachim Herb added a comment -
            sgoetz Sebastian Götz added a comment -

            After reading the comments in JENKINS-31455 I think it has the same origin, but seems to be another problem. Our builds fail each time, a source uses as an external is being change (which happens not very often in our projects). After that I have to run the same build again and it works until the next change to an external.
            Sometimes after restarting Jenkins it also happens, But this not as predictable as the case of a changed svn:external.


              People

              • Assignee:
                Unassigned
                Reporter:
                jnoonan33 James Noonan
              • Votes:
                16 Vote for this issue
                Watchers:
                18 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: