Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25122

Permanent error message "Either Source files, Exec command or both must be supplied"

    Details

    • Similar Issues:

      Description

      No matter how the fields are fed, even if all optional fields are fed, it displays the message "Either Source files, Exec command or both must be supplied", which should disappear as soon as one of the mentionned fields are fed by the user. Everything's working fine but every user that is new to the plugin thinks there's something missing to feed. It also seems a common rule in Jenkins that red messages disappear in real-time as soon as problem is fixed.

        Attachments

          Activity

          Hide
          nico109 Nicolas Baumann added a comment -

          Jenkins version : 1.583
          Publish Over SSH version : 1.11

          Show
          nico109 Nicolas Baumann added a comment - Jenkins version : 1.583 Publish Over SSH version : 1.11
          Hide
          el_schalo Alexander Schäl added a comment -

          indeed - I am a newbie and stuck on this for half an hour

          Show
          el_schalo Alexander Schäl added a comment - indeed - I am a newbie and stuck on this for half an hour
          Hide
          mca140 vikash chandra added a comment -

          I am facing the problem during configuring the send build artifacts over SSH please help me
          Thanks in adv.

          Show
          mca140 vikash chandra added a comment - I am facing the problem during configuring the send build artifacts over SSH please help me Thanks in adv.
          Hide
          brian428 Brian Kotek added a comment -

          Any idea if/when this will be fixed? It's been a problem for over a year, and it's very easy for folks to get confused when they see error messages on every build artifact being transferred.

          Show
          brian428 Brian Kotek added a comment - Any idea if/when this will be fixed? It's been a problem for over a year, and it's very easy for folks to get confused when they see error messages on every build artifact being transferred.
          Hide
          el_schalo Alexander Schäl added a comment -

          Well... it has been categorized as a Major bug - and it is IN PROGRESS...

          For now we should just Thank all the open-source-contributors a wish them a good start in the year 2016 - including a relaxing time until then

          Show
          el_schalo Alexander Schäl added a comment - Well... it has been categorized as a Major bug - and it is IN PROGRESS ... For now we should just Thank all the open-source-contributors a wish them a good start in the year 2016 - including a relaxing time until then
          Hide
          niralntrivedi niral trivedi added a comment -

          I am running the latest version of jenkins:

          Jenkins ver. 2.31
          Publish Over SSH 1.14

          I am also having same issue. Any updates on this please?

          Thanks

          Show
          niralntrivedi niral trivedi added a comment - I am running the latest version of jenkins: Jenkins ver. 2.31 Publish Over SSH 1.14 I am also having same issue. Any updates on this please? Thanks
          Show
          andrewmcgilvray Andrew McGilvray added a comment - Created pull request  https://github.com/jenkinsci/publish-over-ssh-plugin/pull/20
          Hide
          slide_o_mix Alex Earl added a comment -

          My apologies, I thought I had done a release with the PR included, but I have not yet. I will do so soon.

          Show
          slide_o_mix Alex Earl added a comment - My apologies, I thought I had done a release with the PR included, but I have not yet. I will do so soon.

            People

            • Assignee:
              Unassigned
              Reporter:
              nico109 Nicolas Baumann
            • Votes:
              5 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated: