Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25283

jenkins JClouds plugin fails on GCE

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: jclouds-plugin
    • Labels:
    • Environment:
      Jenkins ver. 1.584, jclouds-jenkins ver. 2.8, Centos 6.6
    • Similar Issues:

      Description

      The credentials section of the jclouds-jenkins GCE configuration expects a private key. pasting the correct private key extracted from the .p12 provided by google results in a parsing error.

      Cannot connect to specified cloud, please check the identity and credentials: chars -----BEGIN
      RSA PRIVATE KEY----- AAAAB<SNIP>XmXR ----END RSA PRIVATE KEY---- doesn't contain % line [-----END ]

      If I remove the "----BEGIN RSA", jclouds correctly tells me that % doesn't contain the line -----BEGIN but it seems to be barfing on parsing the "----END" part

      I checked weather pasting the key into the Credential section of the configure jenkins U/I was causing something funny with line breaks, but I placed the key directly into the config.xml's <credential></credential> section, and I'm getting the same error.

      -Aric

        Attachments

          Activity

          unthought Dan M added a comment -

          The problem is that the line breaks in of the pasted key are lost somewhere along the way.

          unthought Dan M added a comment -

          very likely from the fact that 'credentials' is a password field. It doesn't pass the line breaks along.

          tlipcon Todd Lipcon added a comment -

          this still seems to be an issue. I changed it to 'textarea' and it worked OK.

          felfert Fritz Elfert added a comment -

          Fixed in 2.9, using Jenkins Credentials framework.


            People

            • Assignee:
              Unassigned
              Reporter:
              aric aric gardner
            • Votes:
              3 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: