Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      We have 20 or so projects configured in Hudson. We use a combination of CVS
      polling (each project polls CVS once every 5 min, although not all projects at
      same time), and forced nightly build (around 3AM).

      Since upgrading to 1.254 (from 1.233?) the timer isn't working well. It still
      detects the change and queues a build, but the quiet time timer never counts
      down. We have configured a quiet-time of 30 minutes, and it never decreases.
      Ultimately, the nightly build will clear it out of the queue.

        Attachments

          Issue Links

            Activity

            jbennett2091 jbennett2091 added a comment -

            Woops, I meant to say I was using Hudson 1.255 (not 1.254).

            jbennett2091 jbennett2091 added a comment -

            This is still broken as of Hudson 1.279.

            We use CVS and it is set to poll for activity every minute. It executes
            commands like this:
            cvs.exe -q -z3 -n update -PdC -D "Friday, January 30, 2009 2:17:13 PM UTC"

            -n = "Do not execute anything that will change the disk." (i.e. it doesn't
            actually update)
            -D date = timestamp to update since.

            Unfortunately, the date continues to be the date of the last build and doesn't
            seem to change. The net effect is that when a change occurs, it spots the
            change and drops the project into the queue. A minute later, it polls again,
            sees the same change again, and resets the timer. The quiet timer never reaches
            0 because it keeps seeing the same change over and over again (thus thinking it
            has never become quiet).

            Recommend either the "-n" flag be removed, or the "date" be the date of the last
            CVS poll.

            mindless Alan Harder added a comment -

            see my comments in issue #2180 for workaround

                • This issue has been marked as a duplicate of 2180 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                jbennett2091 jbennett2091
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: