Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25386

Jenkins EC2 plugin - new slave for each run

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: ec2-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      I need to ensure that a job has a brand new EC2 slave each time. Currently, the EC2 plugin will use the AMI's 'Idle termination time' to remove the slave. However, the minimum value it can take is 1 minute. During this time, a slave can be used by other queued up jobs.

      Enhancement Request:
      Add a checkbox in AMI section or maybe use 0 as a way to indicate 'single use VM'. If this setting is enable, a slave will be deleted after the job is complete.

        Attachments

          Activity

          johnny_shields Johnny Shields added a comment -

          Francis Upton Please close, this is a dupe of many other tickets.

          johnny_shields Johnny Shields added a comment -

          Dupe of JENKINS-8618


            People

            • Assignee:
              francisu Francis Upton
              Reporter:
              arazasplunk Ali Raza
            • Votes:
              4 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: