Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25407

hudson.remoting.RemotingSystemException: java.io.IOException: Remote call on channel failed: hudson.plugins.tasks.parser.TasksParserResult.addAnnotations

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: tasks-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      After updating Jenkins to version 1.588 and downloading all the plugin's updates, we're getting the following exception on all builds, that use tasks plugin:

      [ERROR] Internal error: hudson.remoting.RemotingSystemException: java.io.IOException: Remote call on channel failed: hudson.plugins.tasks.parser.TasksParserResult.addAnnotations(Ljava/util/Collection;)V -> [Help 1]
      org.apache.maven.InternalErrorException: Internal error: hudson.remoting.RemotingSystemException: java.io.IOException: Remote call on channel failed
      	at org.apache.maven.lifecycle.internal.BuilderCommon.handleBuildError(BuilderCommon.java:128)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:95)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:117)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      	at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:178)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:136)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:71)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      	at hudson.remoting.Request$2.run(Request.java:324)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:724)
      Caused by: hudson.remoting.RemotingSystemException: java.io.IOException: Remote call on channel failed
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:189)
      	at com.sun.proxy.$Proxy7.end(Unknown Source)
      	at hudson.maven.MavenBuildProxy2$Filter.end(MavenBuildProxy2.java:74)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.recordProjectEnded(Maven3Builder.java:568)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.projectSucceeded(Maven3Builder.java:538)
      	at org.eclipse.tycho.core.maven.ChainedExecutionListener.projectSucceeded(ChainedExecutionListener.java:76)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:74)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:42)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:91)
      	... 28 more
      Caused by: java.io.IOException: Remote call on channel failed
      	at hudson.remoting.Channel.call(Channel.java:760)
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:173)
      	... 36 more
      Caused by: java.lang.NoSuchMethodError: hudson.plugins.tasks.parser.TasksParserResult.addAnnotations(Ljava/util/Collection;)V
      	at hudson.plugins.tasks.TasksMavenResultAction.aggregate(TasksMavenResultAction.java:111)
      	at hudson.plugins.tasks.TasksMavenResultAction.createResult(TasksMavenResultAction.java:95)
      	at hudson.plugins.tasks.TasksMavenResultAction.createResult(TasksMavenResultAction.java:26)
      	at hudson.plugins.analysis.core.MavenResultAction.createAggregatedResult(MavenResultAction.java:136)
      	at hudson.plugins.analysis.core.MavenResultAction.update(MavenResultAction.java:115)
      	at hudson.maven.MavenModuleSetBuild.notifyModuleBuild(MavenModuleSetBuild.java:578)
      	at hudson.maven.MavenBuild$ProxyImpl2.end(MavenBuild.java:581)
      	at sun.reflect.GeneratedMethodAccessor571.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at hudson.model.Executor$1.call(Executor.java:579)
      	at hudson.util.InterceptingProxy$1.invoke(InterceptingProxy.java:23)
      	at com.sun.proxy.$Proxy59.end(Unknown Source)
      	at sun.reflect.GeneratedMethodAccessor571.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:320)
      	at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:295)
      	at hudson.remoting.RemoteInvocationHandler$RPCRequest.call(RemoteInvocationHandler.java:254)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:121)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:49)
      	at hudson.remoting.Request$2.run(Request.java:324)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at org.jenkinsci.remoting.CallableDecorator.call(CallableDecorator.java:18)
      	at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
      	at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:724)
      	at ......remote call to channel(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      	at hudson.remoting.UserResponse.retrieve(UserRequest.java:221)
      	at hudson.remoting.Channel.call(Channel.java:752)
      	... 37 more
      [ERROR] 
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR] 
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/InternalErrorException
      

        Attachments

          Issue Links

            Activity

            gilani Syed Amer Gilani added a comment -

            The same happens with the LTS Version 1.580.1

            antoine_aumjaud Antoine Aumjaud added a comment -

            same here.

            Error linked to this commit: https://github.com/jenkinsci/analysis-core-plugin/commit/85faed9ae74508330b9428a309e46f640908fac1
            addAnnotation method returns void before and now an int.

            tasks-4.43 has been compiled with the old version (void).
            https://github.com/jenkinsci/tasks-plugin/blob/master/pom.xml -> 1.58

            To fix this issue, you need to rollbak to analysis-core-1.62 or wait for the pull request: https://github.com/jenkinsci/tasks-plugin/pull/1

            antoine_aumjaud Antoine Aumjaud added a comment - - edited

            I have downgraded the plugin analysis-core:1.64 'Static Analysis Utilities' to version 1.59 (proposed by Jenkins in plugins management) and it works fine!

            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-25405


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                freeshka Dennis F.
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: