Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25457

Server error when viewing pipeline with NOT_BUILT result job.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins: 1.588
      delivery-pipeline-plugin: 0.8.6
    • Similar Issues:

      Description

      Server error was occurred when I've view pipeline that is configured with NOT_BUILT result job.

      Summary of stacktrace log is following:

      11 06, 2014 2:07:59 午前 org.eclipse.jetty.util.log.JavaUtilLog warn
      警告: Error while serving http://debabocho.ariel-networks.com:8080/view/Pipeline/api/json
      java.lang.reflect.InvocationTargetException
      	at sun.reflect.GeneratedMethodAccessor194.invoke(Unknown Source)
      ...
      Caused by: java.io.IOException: Failed to write pipelines
      	at org.kohsuke.stapler.export.Property.writeTo(Property.java:122)
      	at org.kohsuke.stapler.export.Model.writeNestedObjectTo(Model.java:197)
      	at org.kohsuke.stapler.export.Model.writeTo(Model.java:164)
      	at org.kohsuke.stapler.ResponseImpl.serveExposedBean(ResponseImpl.java:267)
      	at hudson.model.Api.doJson(Api.java:205)
      	... 76 more
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.GeneratedMethodAccessor201.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:606)
      	at org.kohsuke.stapler.export.MethodProperty.getValue(MethodProperty.java:66)
      	at org.kohsuke.stapler.export.Property.writeTo(Property.java:116)
      	... 80 more
      Caused by: java.lang.IllegalStateException: Result NOT_BUILT not recognized.
      	at se.diabol.jenkins.pipeline.domain.status.SimpleStatus.resolveStatus(SimpleStatus.java:144)
      	at se.diabol.jenkins.pipeline.domain.Task.getLatestTask(Task.java:142)
      	at se.diabol.jenkins.pipeline.domain.Stage.createLatestStage(Stage.java:188)
      	at se.diabol.jenkins.pipeline.domain.Pipeline.createPipelineLatest(Pipeline.java:149)
      	at se.diabol.jenkins.pipeline.DeliveryPipelineView.getComponent(DeliveryPipelineView.java:324)
      	at se.diabol.jenkins.pipeline.DeliveryPipelineView.getPipelines(DeliveryPipelineView.java:292)
      	... 85 more
      

      And I attached full stacktrace log as error.txt.

        Attachments

          Issue Links

            Activity

            patbos Patrik Boström added a comment -
            patbos Patrik Boström added a comment -

            Merged to master

            patbos Patrik Boström added a comment -

            Will be part of 0.8.8

            buzztaiki Taiki Sugawara added a comment -

            Thanks! This probrem has been fixed in my environment using master HEAD of this plugin.

            patbos Patrik Boström added a comment -

            Released in 0.8.8


              People

              • Assignee:
                patbos Patrik Boström
                Reporter:
                buzztaiki Taiki Sugawara
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: