Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25607

Unable to trigger manual jobs when build-pipeline-plugin 1.4.4 is installed

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Due to a non-backwards compatible change to the constructor of BuildPipelineView, delivery-pipeline-plugin can not trigger manual jobs when build-pipeline 1.4.4 is installed.

      See https://github.com/jenkinsci/build-pipeline-plugin/commit/eeba623fd8b6571372837553a0ea4b227bf4fdf4

      I want to use delivery-pipeline, but also want the fixes that build-pipeline has in 1.4.4 to support jobs in folders. Backing down to 1.4.3 of build-pipeline avoids the constructor issue at the expense of folder support in build-pipeline.

        Attachments

          Activity

            People

            • Assignee:
              patbos Patrik Boström
              Reporter:
              mikepigg Michael Pigg
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: