Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25653

TimeoutStepTest.killingParallel() in aggregator failing on MacOS

    Details

    • Similar Issues:

      Description

      This test (introduced in f7c0db4) fails every time on Darwin/MacOS (at least for me). It runs fine if you run the test on its own (i.e. do not run TimeoutStepTest.basic()). It times out waiting for the build to fail (line 51). It seemed like it might be something to do with not being able to kill all related child processes running in the parallel step, but I'm not sure about that now after adding some logging to the ProcessTree class. Initially it seemed as though it was trying to kill the same process multiple times (I thought maybe that might cause things to hang) but that's not the case either since I've seen it hang even when all the PIDs are unique, so not sure now.

        Attachments

          Activity

          tfennelly Tom FENNELLY created issue -
          tfennelly Tom FENNELLY made changes -
          Field Original Value New Value
          Assignee Jesse Glick [ jglick ] Kohsuke Kawaguchi [ kohsuke ]
          jglick Jesse Glick made changes -
          Assignee Kohsuke Kawaguchi [ kohsuke ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 159628 ] JNJira + In-Review [ 180061 ]
          abayer Andrew Bayer made changes -
          Component/s pipeline-general [ 21692 ]
          abayer Andrew Bayer made changes -
          Component/s workflow-plugin [ 18820 ]
          jglick Jesse Glick made changes -
          Component/s workflow-basic-steps-plugin [ 21712 ]
          Component/s pipeline [ 21692 ]
          jglick Jesse Glick made changes -
          Labels testing
          jglick Jesse Glick added a comment -

          Too old, closing.

          jglick Jesse Glick made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              tfennelly Tom FENNELLY
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: