Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25830

Since upgrading to 1.590 the "Max # of builds to keep with artifacts" option does not seem to work

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      CENTOS 6
    • Similar Issues:

      Description

      before the upgrade when the Max # of builds to keep with artifacts was set it would kick in during the build just after the perforce sync we would see "Deleting old artifacts from #XXX" this does not happen anymore for any builds. The option "Max # of builds to keep" seems to work still.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Core deletes old builds after a build is finished. Are you using p4 plugin, or perforce plugin?

          martin_coughlan martin coughlan added a comment -

          Hi I am using the perforce plugin 1.3.29

          oleg_nenashev Oleg Nenashev added a comment -

          Martin, I cannot reproduce the issue.
          Have you seen something specific in Jenkins system logs?

          martin_coughlan martin coughlan added a comment -

          Hi Oleg

          Sorry about the delay we were offline because of the xmas holidays. We fixed the issue by updating the perforce plugin version. sorry if this wasted a lot of your time.

          thanks
          Martin

          oleg_nenashev Oleg Nenashev added a comment -

          No problem. 1.3.29 was quite unstable due to my changes in variables substitution engine. It may affect the log rotation if Jenkins tries to clean a job's workspace from it.

          Please re-open the issue if it happens again


            People

            • Assignee:
              Unassigned
              Reporter:
              martin_coughlan martin coughlan
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: