Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2611

cvs-tag plugin incorrectly uses both "-r" and "-D" mutually exclusive options

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Solaris

      Description

      The CVS Tag plugin incorrectly invokes "cvs rtag" with both of the mutually
      exclusive "-r" and "-D" options:

      BUILD SUCCESSFUL
      Total time: 1 minute 54 seconds
      Executing tag command: cvs -d
      :pserver:pbdev@sourceforge.uk.db.com:/data/cvsroot/fennel rtag -r
      branch_Fennel_02_12 -D "2008-11-11 21:24" Fennel_SRV_B_02_12_1 fennel-server
      [hudson31254tmp] $ cvs -d
      :pserver:pbdev@sourceforge.uk.db.com:/data/cvsroot/fennel rtag -r
      branch_Fennel_02_12 -D "2008-11-11 21:24" Fennel_SRV_B_02_12_1 fennel-server
      cvs [rtag aborted]: -r and -D options are mutually exclusive
      FATAL: Perform CVS tagging on succesful build failed. exit code=1
      cleaning up /var/tmp/hudson31254tmp
      finished: SUCCESS

      Notice that the "cvs rtag" help shows that the user may apply only one of "-r"
      or "-D":

      uat:fennel-server% cvs --help rtag
      Usage: cvs rtag [-aflRnF] [-b] [-d] [-r rev|-D date] tag modules...
      -a Clear tag from removed files that would not otherwise be tagged.
      -f Force a head revision match if tag/date not found.
      -l Local directory only, not recursive
      -R Process directories recursively.
      -n No execution of 'tag program'
      -d Delete the given Tag.
      -b Make the tag a "branch" tag, allowing concurrent development.
      -r rev Existing revision/tag.
      -D Existing date.
      -F Move tag if it already exists
      (Specify the --help global option for a list of other help options)
      may be copied only under the terms of the GNU General Public License,
      a copy of which can be found with the CVS distribution kit.

      Specify the --help option for further information about CVS
      ###
      uat:fennel-server% cvs --version

      Concurrent Versions System (CVS) 1.11 (client/server)

      Copyright (c) 1989-2000 Brian Berliner, david d `zoo' zuhn,
      Jeff Polk, and other authors

        Issue Links

          Activity

          derekmahar derekmahar added a comment -
          derekmahar derekmahar added a comment -

          Depends on issue 2337 (https://hudson.dev.java.net/issues/show_bug.cgi?id=2337).

              • This issue has been marked as a duplicate of 2553 ***
          derekmahar derekmahar added a comment -

            People

            • Assignee:
              Unassigned
              Reporter:
              derekmahar derekmahar
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: