Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26136

Claim for failed test disappears when a new build finishes

    Details

    • Similar Issues:

      Description

      If I claim a failed test in the latest build (say #128), this claim gets lost as soon as the next build (say #129) finishes.

      The expected behaviour is, that the claim remains (in #128) and - if the "Sticky" checkbox was selected - a claim gets created for the same test in the new build (#129), if it still fails.

      I'm willing to help with the fix because this would be a very useful feature for our team if it worked as expected.

        Attachments

          Issue Links

            Activity

            Hide
            rocco LuFrija added a comment -

            Apparently we are also affected by this problem, even though we are currently using a newer version of the plugin (2.13) and Jenkins (2.19.4). The claim gets lost in the subsequent build even if the option "sticky" is selected. The problem does not show up in every job, but rather only in some.

            We are using the claim plugin inside scripted pipeline.

            Show
            rocco LuFrija added a comment - Apparently we are also affected by this problem, even though we are currently using a newer version of the plugin (2.13) and Jenkins (2.19.4). The claim gets lost in the subsequent build even if the option "sticky" is selected. The problem does not show up in every job, but rather only in some. We are using the claim plugin inside scripted pipeline.
            Hide
            greybird Arnaud TAMAILLON added a comment -

            Hi LuFrija,

            Would you be able to provide some details on the use case, and maybe a reproducer ?
            Are claims lost when encountering a build where tests are not run for example (due to compile failure ?), or some other pattern ?

            Show
            greybird Arnaud TAMAILLON added a comment - Hi LuFrija , Would you be able to provide some details on the use case, and maybe a reproducer ? Are claims lost when encountering a build where tests are not run for example (due to compile failure ?), or some other pattern ?
            Hide
            rocco LuFrija added a comment -

            hi Arnaud TAMAILLON , we actually got hit by

            https://issues.jenkins-ci.org/browse/JENKINS-30413

            So basically we just made sure not to have tests with same name and the issue was solved. So my case ha nothing to do with the claim plugin itself.

            Show
            rocco LuFrija added a comment - hi Arnaud TAMAILLON , we actually got hit by https://issues.jenkins-ci.org/browse/JENKINS-30413 So basically we just made sure not to have tests with same name and the issue was solved. So my case ha nothing to do with the claim plugin itself.
            Hide
            greybird Arnaud TAMAILLON added a comment -

            Hi LuFrija,

            Thanks for your answer!
            I will close this issue then.

            Arnaud

            Show
            greybird Arnaud TAMAILLON added a comment - Hi LuFrija , Thanks for your answer! I will close this issue then. Arnaud

              People

              • Assignee:
                greybird Arnaud TAMAILLON
                Reporter:
                msa Michael Schaufelberger
              • Votes:
                3 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: