Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2614

cvs update fails if there are non-ascii characters in filename

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Hudson job build fails if a filename contains swedish non-ascii character.
      It works fine in command line cvs client

      started
      [workspace] $ cvs -q -z3 update -PdC -D "Wednesday, November 12, 2008 9:48:21 AM
      UTC"
      U docs/Invalid Svensk Tecken åäö1.txt
      U docs/Invalid Svensk Tecken åäö2.txt
      U docs/Invalid Svensk Tecken åäö3.txt
      $ computing changelog
      cvs log: nothing known about Invalid Svensk Tecken ���1.txt
      cvs log: nothing known about Invalid Svensk Tecken ���2.txt
      cvs log: nothing known about Invalid Svensk Tecken ���3.txt
      ERROR: cvs exited with error code 1
      Command line was [Executing 'cvs' with arguments:
      '-d:ext:dailybuild@cvs.cinnober.com:/cvs/liffe'
      'log'
      '-d'
      '>=2008-11-11'
      '--'
      'docs/Invalid Svensk Tecken ���1.txt'
      'docs/Invalid Svensk Tecken ���2.txt'
      'docs/Invalid Svensk Tecken ���3.txt'

      The ' characters around the executable and arguments are
      not part of the command.
      ] in /home/cin01/.hudson/jobs/CvsTest/workspace
      Input text:
      START==>null<==END
      Working directory is /home/cin01/.hudson/jobs/CvsTest/workspace
      cvs exited with error code 1
      Command line was [Executing 'cvs' with arguments:
      '-d:ext:dailybuild@cvs.dummy.com:/cvs/repository'
      'log'
      '-d'
      '>=2008-11-11'
      '--'
      'docs/Invalid Svensk Tecken ���1.txt'
      'docs/Invalid Svensk Tecken ���2.txt'
      'docs/Invalid Svensk Tecken ���3.txt'

      The ' characters around the executable and arguments are
      not part of the command.
      ] in /home/cin01/.hudson/jobs/CvsTest/workspace
      Input text:
      START==>null<==END
      at
      hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.runCommand(AbstractCvsTask.java:387)
      at
      hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.execute(AbstractCvsTask.java:457)
      at
      hudson.org.apache.tools.ant.taskdefs.cvslib.ChangeLogTask.execute(ChangeLogTask.java:293)
      at hudson.scm.CVSSCM$4.invoke(CVSSCM.java:793)
      at hudson.scm.CVSSCM$4.invoke(CVSSCM.java:728)
      at hudson.FilePath.act(FilePath.java:389)
      at hudson.scm.CVSSCM.calcChangeLog(CVSSCM.java:728)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:298)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:667)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:261)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:235)
      at hudson.model.Run.run(Run.java:817)
      at hudson.model.Build.run(Build.java:88)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:88)
      Sending e-mails to: me
      finished: FAILURE

        Attachments

          Issue Links

            Activity

            mc1arke Michael Clarke added a comment -

            This was caused by the entries file being updated wrongly on checkout. Cvs plugin 2.0 uses a java cvs library which does not require manual editing of these files so resolves this issue

            ankitgupta17 Ankit Gupta added a comment -

            Hi All,

            Has the issue been fixed. I m stuck because of this. Please let me know the solution.

            ankitgupta17 Ankit Gupta added a comment -

            PFA for the Environment details

            ankitgupta17 Ankit Gupta added a comment -

            I have fixed the issue .....

            nohup nice $JAVA -Xmx512m -Dfile.encoding=Cp1252 -DHUDSON_HOME=/var/Hudson/.hudson -jar $HUDSON_WAR --httpPort=$HTTP_PORT> $HUDSON_LOG 2>&1 &

            Added -Dfile.encoding=Cp1252 and again tested .... It was working fine.

            mc1arke Michael Clarke added a comment -

            @Ankit Gupta - your issue is for Hudson, not Jenkins. Please raise an issue on the relevant Eclipse bug tracker. Your workaround is not a suitable suggestion for Jenkins as this issue does not exist in newer versions of the CVS plugin


              People

              • Assignee:
                mc1arke Michael Clarke
                Reporter:
                rusalt rusalt
              • Votes:
                6 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: