Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26200

Failed to scout net.hockeyapp.jenkins.releaseNotes.ChangelogReleaseNotes$DescriptorImpl

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: hockeyapp-plugin
    • Labels:
      None
    • Environment:
      Jenkins version 1.595 running on OS X 10.9.5
      Pertinent installed plugins: git, gerrit-trigger, Xcode
    • Similar Issues:

      Description

      Seems like since updating to 1.2.0 of hockeyapp, Jenkins has been unable to load the plugin. Here's a excerpt of the log, with the full log attached as a file:

      Dec 22, 2014 1:50:45 PM WARNING hudson.ExtensionFinder$Sezpoz scout
      Failed to scout net.hockeyapp.jenkins.releaseNotes.ChangelogReleaseNotes$DescriptorImpl
      java.lang.InstantiationException: java.lang.UnsupportedClassVersionError: net/hockeyapp/jenkins/releaseNotes/ChangelogReleaseNotes$DescriptorImpl : Unsupported major.minor version 51.0
      at net.java.sezpoz.IndexItem.element(IndexItem.java:146)
      at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:666)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:349)
      at hudson.ExtensionList.load(ExtensionList.java:300)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:253)
      at hudson.ExtensionList.iterator(ExtensionList.java:143)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:348)
      at hudson.ExtensionList.load(ExtensionList.java:300)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:253)
      at hudson.ExtensionList.size(ExtensionList.java:162)
      at com.sonyericsson.hudson.plugins.gerrit.trigger.PluginImpl.postInitialize(PluginImpl.java:298)
      at hudson.PluginManager$2$1$2.run(PluginManager.java:386)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:903)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)
      at java.lang.Thread.run(Thread.java:695)
      Caused by: java.lang.UnsupportedClassVersionError: net/hockeyapp/jenkins/releaseNotes/ChangelogReleaseNotes$DescriptorImpl : Unsupported major.minor version 51.0
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
      at jenkins.util.AntClassLoader.defineClassFromData(AntClassLoader.java:1138)
      at hudson.ClassicPluginStrategy$AntClassLoader2.defineClassFromData(ClassicPluginStrategy.java:768)
      at jenkins.util.AntClassLoader.getClassFromStream(AntClassLoader.java:1309)
      at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
      at sun.reflect.GeneratedMethodAccessor3.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at jenkins.ClassLoaderReflectionToolkit.invoke(ClassLoaderReflectionToolkit.java:44)
      at jenkins.ClassLoaderReflectionToolkit._findClass(ClassLoaderReflectionToolkit.java:86)
      at hudson.PluginManager$UberClassLoader.findClass(PluginManager.java:1110)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      at net.java.sezpoz.IndexItem.element(IndexItem.java:134)
      ... 19 more

      Can confirm downgrading to 1.1.0 resolves this issue.

        Attachments

          Activity

          simx Simone Manganelli added a comment -

          We're also seeing this issue with the HockeyApp plugin version 1.2.0. Jenkins 1.578, OS X 10.9.5. The "Upload to HockeyApp" menu item just does not appear. Manually installing version 1.1.0 of the plugin works properly.

          tony Tony Le added a comment -

          I was having trouble seeing the "Upload to HockeyApp" menu item the other day as well.

          I fixed it by upgrading java to java 8.

          The "Upload to HockeyApp" should appear if you have >java 6 AFAIK. Hope that helps.

          mezpahlan Mez Pahlan added a comment -

          Is this still something for consideration? I note this is quite an old item. If not I'll close this in a week.

          mezpahlan Mez Pahlan added a comment -

          No response within a week. Closing.


            People

            • Assignee:
              msmollin Matt Smollinger
              Reporter:
              msmollin Matt Smollinger
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: