Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26375

Team Foundation Server Plugin (TFS) creates bogus users in 3.0 and later

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      It looks like pull request 17 in v3.0.0 changed the way it names users detected by changeset from plain userID to domain\userID. This blew up my Jenkins user identities and build emails.

      TFS plugin v2.0 looks like it was just getting back the plain username for a changeset, so it was able to build a link to an existing Jenkins user on the changes screen. We're using the Active Directory plugin/strategy for authentication and it creates the Jenkins users as their simple userID and not domain\userid (which we like and which cooperates with our email address structures).

      TFS plugin v3.0.0 and later return domain\username, which is perceived as a new, unique user. Emails end up going to that new user account (which isn't a valid email address), and the build changes view's user links are all pointed to the bogus accounts. I rolled back to TFS plugin v2.0 and everything is back to normal now, but our build history is fairly polluted. We'd also love to be able to use the build labeling feature from the latest version.

      Please contact me if you need repro help or screenshots or anything else.

        Attachments

          Issue Links

            Activity

            jessejacob Jesse Jacob created issue -
            jessejacob Jesse Jacob made changes -
            Field Original Value New Value
            Labels plugin security user-experience windows plugin security tfs tfs-plugin user-experience windows
            jessejacob Jesse Jacob added a comment -

            I put up a bounty for this, as well, since I don't have time to fix it. I just tested with 4.0 and noticed the problem is still there so I still can't use anything newer than 2.0 It's worth $100 if somebody fixes it:
            https://freedomsponsors.org/issue/611/team-foundation-server-plugin-tfs-creates-bogus-users-in-30-and-later

            oli_at_jsi Olivier Dagenais made changes -
            Assignee redsolo [ redsolo ] Olivier Dagenais [ oli_at_jsi ]
            elordahl Eric Lordahl added a comment - - edited

            i have a fix in place for this, and will submit a PR when i have a full understanding of all use cases of this plugin. My changes simply drop the domain when looking up the user, which might not be correct if your users have the domain prepended.

            Question: Olivier Dagenais, are there scenarios where Jenkins will create a user-id with the domain prepended? It does not appear to work this way in my instance, but i see that Jenkins User.get will replace '\' with '_'.

            elordahl Eric Lordahl added a comment -

            https://github.com/jenkinsci/tfs-plugin/pull/73 submitted. As i specified in the PR, i'm not entirely sure of the big picture, but it satisfies my local, AD, and LDAP use cases.

            Hopefully it'll get merged soon.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 160440 ] JNJira + In-Review [ 180353 ]
            recampbell Ryan Campbell added a comment - - edited

            Seems like the #73 above was superceded by #40 so I think this is resolved if I understand the maintainer's comments.

            Seems like this was fixed in tfs-5.3.0, but I'm leaving for maintainer to confirm.

            oli_at_jsi Olivier Dagenais made changes -
            Assignee Olivier Dagenais [ oli_at_jsi ] David Staheli [ dastahel ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-1556 (Web Link)" [ 18649 ]
            kelliejos Kellie Jos made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                dastahel David Staheli
                Reporter:
                jessejacob Jesse Jacob
              • Votes:
                4 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: