Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26458

E155021: This client is too old to work with the working copy

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Not A Defect
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      CentOS 6, Jenkins 1.596, subversion-plugin 2.5, Java 1.7.0_71, visualsvn server 2.7.3
    • Similar Issues:

      Description

      Recently (these few days), I'v got the following error and can't go on building.
      This error happens all the time on master job. However, it just occurs on
      feature branch jobs occationally, but not always.

      I've tried to checkout on the same box, directly from command line, and it goes
      just fine (svn 1.7.18).

      Checking out https://192.168.3.15/svn/www/Web/V2/trunk at revision '2015-01-16T17:32:11.806 +0800'
      ERROR: Failed to check out https://192.168.3.15/svn/www/Web/V2/trunk
      org.tmatesoft.svn.core.SVNException: svn: E155021: This client is too old to work with the working copy at
      '/var/lib/jenkins/jobs/www/workspace' (format '100').
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.wc17.db.SVNWCDbRoot.<init>(SVNWCDbRoot.java:104)
      at org.tmatesoft.svn.core.internal.wc17.db.SVNWCDb.init(SVNWCDb.java:242)
      at org.tmatesoft.svn.core.internal.wc17.SVNWCContext.initWC(SVNWCContext.java:4979)
      at org.tmatesoft.svn.core.internal.wc17.SVNWCContext.initializeWC(SVNWCContext.java:4928)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgAbstractUpdate.checkout(SvnNgAbstractUpdate.java:796)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgCheckout.run(SvnNgCheckout.java:26)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgCheckout.run(SvnNgCheckout.java:11)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgOperationRunner.run(SvnNgOperationRunner.java:20)
      at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      at hudson.scm.subversion.CheckoutUpdater$1.perform(CheckoutUpdater.java:115)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:170)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:133)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:991)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:972)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:948)
      at hudson.FilePath.act(FilePath.java:981)
      at hudson.FilePath.act(FilePath.java:959)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:897)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:833)
      at hudson.scm.SCM.checkout(SCM.java:484)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1265)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
      at hudson.model.Run.execute(Run.java:1759)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      java.io.IOException: Failed to check out https://192.168.3.15/svn/www/Web/V2/trunk
      at hudson.scm.subversion.CheckoutUpdater$1.perform(CheckoutUpdater.java:126)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:170)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:133)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:162)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:991)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:972)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:948)
      at hudson.FilePath.act(FilePath.java:981)
      at hudson.FilePath.act(FilePath.java:959)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:897)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:833)
      at hudson.scm.SCM.checkout(SCM.java:484)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1265)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
      at hudson.model.Run.execute(Run.java:1759)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)
      Caused by: org.tmatesoft.svn.core.SVNException: svn: E155021: This client is too old to work with the working copy at
      '/var/lib/jenkins/jobs/www/workspace' (format '100').
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.wc17.db.SVNWCDbRoot.<init>(SVNWCDbRoot.java:104)
      at org.tmatesoft.svn.core.internal.wc17.db.SVNWCDb.init(SVNWCDb.java:242)
      at org.tmatesoft.svn.core.internal.wc17.SVNWCContext.initWC(SVNWCContext.java:4979)
      at org.tmatesoft.svn.core.internal.wc17.SVNWCContext.initializeWC(SVNWCContext.java:4928)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgAbstractUpdate.checkout(SvnNgAbstractUpdate.java:796)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgCheckout.run(SvnNgCheckout.java:26)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgCheckout.run(SvnNgCheckout.java:11)
      at org.tmatesoft.svn.core.internal.wc2.ng.SvnNgOperationRunner.run(SvnNgOperationRunner.java:20)
      at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
      at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
      at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
      at hudson.scm.subversion.CheckoutUpdater$1.perform(CheckoutUpdater.java:115)
      ... 20 more

        Attachments

          Issue Links

            Activity

            slawomir_czarko Slawomir Czarko added a comment -

            In my build scripts I need to execute various SVN commands - add, delete, status, commit. But that's not really relevant to this problem. I was replying to the comment that "It is very important that the workspace is managed by Subversion Plugin." and explaining why I need to use subversion CLI and why I cannot update SVN version from 1.7 to 1.8 in the "Jenkins > configuration".

            I can reproduce this bug with a basic job which has one SVN module defined - test-subversion.xml. It fails every time if in global Jenkins settings subversion version is set to 1.7. With 1.8 it works.

            I'm not sure but I think when it fails the SVN working copy seems to be corrupted. Normally with 1.7 SVN working copy if you run this command :
            sqlite3 .svn/wc.db "PRAGMA user_version"
            you get 29.
            With 1.8 you get 31.
            But when this error happens I get 100 which is the value mentioned in the error message. This would explain why the plugin is unable to checkout the code.

            Jenkins build output when it fails - test-subversion-consoleText

            svasek Milos Svasek added a comment - - edited

            Please let us decide which version of working copy we want to use.
            We need to stay on version 1.7 in my company but it's not possible with this plugin since version 2.5.x.
            Why do we have options to set another/older version in global config of Jenkins since there is no another working option then 1.8?
            Definitely, this is a bug in Subversion plugin.

            svasek Milos Svasek added a comment -

            It seems that switch Jenkins global setting to 1.8 an then back to 1.7 workaround the issue.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: christ66
            Path:
            src/main/java/hudson/scm/subversion/CheckoutUpdater.java
            src/test/java/hudson/scm/SVNWorkingCopyTest.java
            http://jenkins-ci.org/commit/subversion-plugin/7fd8a5a9e39e314c5578f68c3271dd4ea691bcd2
            Log:
            JENKINS-26458 Guard against a workspace format of 100.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Manuel Recena
            Path:
            src/main/java/hudson/scm/SubversionWorkspaceSelector.java
            src/main/java/hudson/scm/subversion/CheckoutUpdater.java
            src/test/java/hudson/scm/SVNWorkingCopyTest.java
            http://jenkins-ci.org/commit/subversion-plugin/b121992a56d6845ae3b5974e30f292fd1305ff02
            Log:
            Merge pull request #128 from christ66/JENKINS-26458

            JENKINS-26458 Guard against a workspace format of 100.

            Compare: https://github.com/jenkinsci/subversion-plugin/compare/bc710b87e21b...b121992a56d6


              People

              • Assignee:
                recena Manuel Recena Soto
                Reporter:
                eidng8 Jackey Cheung
              • Votes:
                16 Vote for this issue
                Watchers:
                33 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: