Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26473

SVN cannot authenticate using Negotiate

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      Jenkins version 1.593, SVN plugin version 2.5, SVN version 1.8, Credentials plugin version 1.2
    • Similar Issues:

      Description

      I am getting an error when I try to checkout my repositories:

      Unable to access [url removed] : svn: E170001: Negotiate authentication failed: 'No valid credentials provided'

      I have supplied credentials through Jenkins; on the command-line, I can checkout the exact url it's pointed at using the exact credentials specified simply as username and password arguments. I have also tried adding "Additional Credentials", but that doesn't help. Storing credentials for command-line svn did not help, nor did removing the entire credentials store for user Jenkins in case that was interfering.

        Attachments

          Issue Links

            Activity

            skymoo Adam Mercer added a comment -

            We're also seeing this error with Jenkins 1.580.2, Credentials plugin 1.20, and Subversion plugin 2.5

            We can use the same credentials on the command and successfully access the repository.

            skymoo Adam Mercer added a comment -

            I noticed that version 1.21 of the credentials plugin was available, I updated to this and still see the same problem.

            schristou Steven Christou added a comment -

            Duplicate of JENKINS-26158.


              People

              • Assignee:
                schristou Steven Christou
                Reporter:
                bgreen Bayley Gaillard
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: