Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26485

need global slave/build permission when using job restriction at slaves

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: role-strategy-plugin
    • Labels:
      None
    • Environment:
      CentOS release 5.11
      jenkins core 1.580.2
      job restriction plugin 0.4
      role strategy plugin 2.2.0
      LDAP plugin 1.11
    • Similar Issues:

      Description

      When restricting job execution at slave to LDAP groupID via job restriction plugin, one needs to set additional "slave/build" permission for the user in the global role.
      For the "slave/connect" and "slave/disconnect" permission this is not needed, here it is enough to assign this via a slave role.

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          I was unable to reproduce it though. Some additional information like Role Strategy configuration and ldapsearch dump would be useful.

          oleg_nenashev Oleg Nenashev added a comment -

          Nothing to do with job-restrictions


            People

            • Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              hbockelmann hbockelmann
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: