Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26752

"Execute concurrent builds if necessary" does not work properly on parameterized alpha jobs

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: build-flow-plugin, core
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Steps to reproduce:
      1. Create a parameterized alpha job with Git support. As in attached screenshot.
      2. Enable "Execute concurrent builds if necessary"
      3. Launch first alpha job with specific commit.
      4. Wait for it to start running some jobs, but still have some left in queue.
      5. Launch another alpha job with a different commit.
      6. Those jobs, which were running will be requeued to run again with for the new commit. This is as expected. However, those jobs, which were still in queue, will not be queued additionally, because Jenkins somehow thinks that they are exactly the same.
      7. The end result is that some of the jobs will be run for one commit, while some for 2 commits. Instead of having 2x runs for the same amount of jobs, only 1-2x runs will be made, because some of the jobs won't be rescheduled to run with the new parameters (commit).

      http://stackoverflow.com/questions/11089133/is-there-a-way-to-avoid-duplicate-parameterized-jenkins-builds also describes the same issue.

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          What's an alpha job?

          Why should jobs with the exact same parameters be queued twice? Aren't they identical?

          ernetas Ernestas Lukoševičius added a comment -

          Sorry, that's probably from my own terminology. It's a job, which starts other jobs.

          They shouldn't. But neither should jobs with different parameters be queued once, which is happening...

          danielbeck Daniel Beck added a comment -

          It's still not clear to me whether there's a real problem here.

          Could you provide exhaustive steps to reproduce this issue in a minimal test case, i.e. leave out actual Git repos if possible, use only e.g. parameterized builds and and parameterized trigger; but explain that in detail. Be specific as to what need to be configured, and how. For example, don't just imply that one job somehow starts others, write instead something like Add a 'Trigger parameterized build on other projects' post-build action, have it trigger the project 'foo' with 'Current build parameters' selected from the 'Add Parameters' dropdown, then save the configuration.

          ernetas Ernestas Lukoševičius added a comment -

          All fine. Not a bug.


            People

            • Assignee:
              ernetas Ernestas Lukoševičius
              Reporter:
              ernetas Ernestas Lukoševičius
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: